How do I enable Wifi calling (Galaxy S7)

#1

I am not seeing the wifi calling icon in my status bar when placing or receiving phone calls.

On the call settings screen it says that WiFi calling is disabled.

On the wifi call settings screen the disabled option has not been activated and Wifi calling preferred is activated

I am still stumbling around learning about my Galaxy S7 and Republic Wireless. I suppose I may have changed one or more settings somewhere, in my explorations, that may be causing the issue, but I have no idea where to start troubleshooting.

How do I get WIFI calling enabled?

Note: I wanted to include some screenshots from my phone, but when creating this post from my phone, I can’t figure out how to do so. I saw the option from desktop, but not my phone. What am I overlooking?

#2

Hi @Graammm,

There is nothing proactive that need be done to enable WiFi calling on your S7 with Republic. The setting you reference is needed for some other service providers that support WiFi calling on the S7 and should be left off.

Republic manages its’ unique blended WiFi/cell calling via the Republic app. When making calls, do you see that you’re on the “Republic Network”. If so, that’s a WiFi call.

#3

Thanks @rolandh … yes … I do see that I’m on “Republic Network.” Of course, I would have not noticed that if you hadn’t mentioned it. :slight_smile:

1 Like
#4

You’re most welcome and being new to Republic, there really isn’t a reason one should know that. Anyway, we were all new once. I find helping others to be a satisfying way to pay back those who helped me. :relaxed:

1 Like
closed #5

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

Message an
Expert customer