How do I get a replacement SIM for Moto E 2nd Gen?


#1

i lost my SIM card for my Moto e 2nd generation republic phone
How can I get a new one ? It was having some issues, and I probably need a new SIM card to try and trouble shoot the problem.
i would try and reset the phone but it would turn off before I could select any of the items in the drop down box, such as start in safe mode, etc. If that isn’t fixable, I guess I won’t need a new SIM card after all.


#2

for Legacy phones a SIM may be requested though a support ticket Tickets | Republic Wireless


#3

Hi @janelle.bku4gn,

Candidly, your intuition is correct. The issues you describe don’t sound like something a new SIM would resolve.

When you say you tried to reset the phone, do you mean a factory reset or restarting it? If the phone is powering down for no apparent reason, I’d suggest starting with clearing both the app and Android system caches. Here’s how: Clearing the Cache – Republic Help.

As an aside, your Moto E2 should function as a phone SIM or no SIM. It’s SIM provides access to Sprint’s 4G LTE data network for Internet access nothing else.


#4

we are trying to factory reset… the hold down the power and the up volume (or was that the down volume?)
there is not any way to do anything with the phone at all…it just turns on for about 4 seconds then off again…doesn’t stop. we tried holding down the buttons to reset and can’t get anything selected before it turns off again… i’m guessing it might not be fixable.

good to know that the phone could function without the SIM card. I figured that i would need to get one before I could try and fix it


#5

To prevent it from powering on while doing the procedure. Press and hold the volume down first, while stlll holding that press and hold the power button. Trying to press and hold both at the same instant often results in the phone powering back on. One day somebody will figure out how to rewrite the instructions.

:flight_departure:


#6

yes that is helpful information and it does pop up the screen to select different functions, but it won’t allow me to select one. Alas, it turns off even when I am not pressing the on/off button :frowning:


#7

Factory Reset – Republic Help
to select it’s should be the volume up button

  1. Turn off your phone.
  2. Unplug any USB or power cables from the phone.
  3. Press and hold both the VOL DOWN and POWER buttons at the same time for 2-3 seconds, then release both buttons.
  4. The phone will display different boot options. Use VOL DOWN to scroll through the options to RECOVERY and press the VOL UP button to select.
  5. The phone will display the Motorola logo, then the Android figure lying down with an exclamation point with the words No Command underneath. Press and hold the POWER button and tap the VOL UP button. Note: If you wait too long to make a selection, the phone will reboot and you will need to start the process again.
  6. The phone will display additional menu options, with text in blue. Use the VOL DOWN button to scroll to Wipe data/factory reset and press the POWER button to select it.
  7. Use the VOL DOWN button to select YES- delete all user data.
  8. Press the POWER button to confirm.
  9. Once formatting is complete, press the POWER button to confirm a REBOOT.
  10. Your phone will reboot normally.

#8

so this s a great list of instructions! thank you for sharing that, it is very helpful.

however, my cell phone is messed up, i guess.

it won’t turn off. I unplugged it and tried to follow the instructions and it literally turns itself back on

I can briefly get the screen to select options, but my up volume just toggles through the list instead of making a selection and when I try to use the power button, it doesn’t make the selection.

it just keeps going off/on … it is in an off/on cycle which doesn’t end, ever… i don’t touch anything and it turns on for 4 seconds, then off. can’t make it shut off. I get the “M” on the white background, then it’s turned off.

is there no hope? If not, I guess not. However, we like our republic plan and will loose it when a new phone.
thanks for any additional help


#9

If you wish to keep your plan, you can do that if you purchase a legacy Republic phone (i.e., a Moto E1, E2, G1, G3, X1, or X2).

These can generally be found used on sites like ebay or Swappa (here is a link to some guidance on purchasing a used phone if you wish to do that: Buying and Selling Used Republic Wireless Phones – Republic Help).

FYI, here is a link to current ebay listings: https://www.ebay.com/sch/i.html?_from=R40&_trksid=p2056350.m570.l2632.R2.TR4.TRC1.A0.H0.X"republic+wireless"+phon.TRS0&_nkw=republic+wireless+phone&_sacat=9355

I also suggest that you open a ticket with Republic support staff to see if any additional troubleshooting might help, and what options they might have for you.


#10

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.