How do I get Moto G4 Plus to use wifi for calling?

calling

#1

How do I get my Moto G4 Plus to use WIFI for calling?

My Moto G4 Plus (purchased from Republic, updated to Nougat) always says it’s using the cell network when I make a phone call even though I’m connected to my home WIFI network with a strong signal and the WIFI icon is a solid white wedge shape. Data for web browsing, etc., does seem to use the WIFI. I have Norton Mobile and Norton WiFi Privacy apps installed. I’ve tried turning Norton WIFI Privacy (a VPN) off and that makes no difference.


#2

VPNs will generally prevent wifi calling from working, so that’s a sure reason it won’t work. If the phone is connected to wifi, but refusing to make wifi calls, this generally means that some testing of the connection that the phone is doing is failing and the phone doesn’t think it can provide a quality calling experience over wifi.

The first step here is usually just a restart of the wifi router. A quick unplug, count to 10, replug. Does that change your abiity to make calls?


#3

I’m not sure if what you say about a VPN is necessarily true. I’ve been using NoRoot Firewall to control my cell data usage, and my Wifi calling hasn’t been effected at all. However, NoRoot is just using it to control traffic, other than that it isn’t routing my traffic to another site for processing like Norton probably is for @johnr.i85aia.


#4

Another good test to do to see what’s going on is to turn on Airplane mode. Once Airplane mode is turned on, turn back on your WiFi manually… Once you are connected to your Wifi, be sure that your Republic Notification says “Connected to WiFi – You’re connected to (Name of your network here)” Now go ahead and try to make a call.
If it doesn’t it may be worth looking at the permissions for the Republic App as well.


#5

That’s not really a VPN. You see a VPN notice because the local firewall is proxying your connection locally, so that it can control data flow. In a real VPN (that provides privacy/encryption) the data is passing through a 3rd party server and the added latency/jitter this introduces to the equation usually makes wifi calling unreliable.


#6

Thanks, Benjaminf.haklmn. I tried turning on Airplane Mode and then turning WiFi back on. Then when I try to call it says to turn off Airplane Mode before calling. I have tried restarting the modem–no change. The modem is providing good high speed interconnect access and nothing else was using the internet during my recent testing. The Republic Notification says something like calls and connections through Cell, WiFi data.

BTW, Norton WiFi Privacy is a true VPN which routes you through another server, but I have tried repeatedly turning it off with no change.

So I’m still at loss to understand what’s going on.


#7

@johnr.i85aia What did the notification say when you had airplane mode on and WiFi turned back on?

It may be worth looking at the permissions for the Republic App. The easiest way to do that is to long press the Republic App in your App drawer (or home screen if you have a shortcut there) and then drag the icon over to the top of the screen where it says “App Info.” This will pull up the details about the app. On that screen tap permissions, make sure all of them are on with the green switch on the right hand side… I’ll try to make some screenshots if I find some free time in the next 24 hrs.

Hope this helps!


#8

I finally got calling by WiFi working. In the Republic app I went to the fourth screen and selected “Advanced settings”. In there I turned on “Allow manual handover”. Then I hit the “Reset degraded service checks”. After that it seems to be able to make calls with only WiFi available. I verified this by turning Airplane mode on and then re-enabling WiFi, as benjaminf.haklmn suggested.

Thanks for the help.


#9

Happy you got everything working now! Enjoy your WiFi calling! Happy to have helped!


#10

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.