How do I prevent my phone from searching for Wi-Fi networks?

I would like my phone to remain on “Cell” until I manually change it to Wi-Fi. Does anyone know how I can adjust the settings so it does this? I have a Moto X 2nd Generation phone. Thanks in advance.

this needs to be done in two locations

  1. Republic app

open app and move to setting tab (gear icon in upper right), then WiFi setting : uncheck the ask me to join WiFi networks

  1. in android setting (gear icon in app draw or the little gear in the upright on quick setting screen (2 finger pull down or 2 single finger pull down) --> Wi-Fi --> Wi-Fi setting menu drop down (3 vertical dots in upper right ) tap “Advanced” then turn off both “Network notification” and “Scanning always available”

I have all those settings as you mentioned already - that is why I can’t figure out why my phone keeps turning the wi-fi on. Sometimes when I manually turn it off, during a walk outside it turns itself on again.

You probably have one of the Cable WiFi partners networks saved in the Republic app WiFi saved setting.

You will need to go into the Republic app WiFi settings menu and remove both the partner’s network and Cable WiFI to get it to stop. If you don’t remove both of them, the phone will continue to try to connect to these two networks.

Cable WiFi® | Internet access brought to consumers through a collaboration among U.S. Internet service providers

The only saved Networks I have in the settings, are locations far away - like Starbucks etc… I don’t even have my my home Wi Fi in there. It is somehow reading , and searching for available networks all the time it seems. The other thing is almost every time I turn my phone on, it says Wi Fi settings have been updated.

If I turn my phone off and back on with the phone not plugged into the charger, it goes through the activation process, but no update to WiFi settings. If I just power the screen off, my lock screen comes up to enter my pin, but again no WiFi settings have been updated.

You might try putting the phone in safe mode and test to see if the phone is still trying to connect to WiFi networks. If the phone behaves in safe mode then you have a non-native app that is causing issues. Safe Mode

The Cable WiFi issue is very common for those of us using the older phones. Around where I live, I pass about 10 to 12 of Xfinity’s outdoor hot spots within one mile of my house, and I never have an issue with them. But you say you don’t have any of partners and Cable WiFi saved in the Republic app. I suppose some other saved network could be causing issues too.

Try changing your Location settings. Go to:

Settings->Location->Mode

and set it to ‘Device only’ to see if that helps.

Another thing that can cause strange problems such as this is corrupted Android OS files. So use the section on Android cache rather than app caches:

Clearing the Cache

I never have my location on…but thank you.

I did this and it still occured. Someone wrote that having Norton on a phone can cause this to happen.

Apps and web pages can request your location but I see you tried this and it didn’t work.

FYI: The only way to keep your Wi-Fi radio turned off is to put the phone in Airplane Mode. But your cell radio will be off too.

And, at least for 3.0 phones, when your phone reboots the Wi-Fi radio will be turned back on within a minute or two by the Republic app. Your cell radio will stay off. (I just tried this.)

Message an
Expert customer