How do I remove google feed when I swipe left from my home screen on MOTO E 2nd gen

How do I remove the google feed screen when I swipe left from my Home Screen on MOTO E 2nd gen? I have went into google settings and your feed but don’t see anything to shut it off. This just started and never had it before.

That is part of the standard launcher on the phone and can’t be disabled. The only way to get rid of it would be to replace the launcher on the phone with an alternative. There are many.

Here are some well known ones.



2 Likes

Have you checked Your feed in Goggle app settings? It may have been inadvertently enabled.

That isn’t a solution. Google now feed needs to be disabled. But how?

On the MOTO X, I had this disabled at one point, just a couple of days ago it mysteriously turned itself back on. Now i’m unable to disable the Google Feed…

I have a google pixel a bit different but I also had the google feed. I turned it off by long pressing on the home screen to get the home screen menu then selecting settings and turning it off. On some phones you can turn it off in the google app from its settings menu. Hope that this helps.

1 Like

I don’t believe this will work on your phone, because it is integrated into the launcher, as I stated, but you can check.

that didn’t help on the Moto X 2nd generation.

This video didn’t remove the google now feed on the Moto X 2nd gen

As I’ll repeat above. Motorola has chosen to use a launcher where this is integrated and not able to be disabled. Replacing the launcher with one I listed above (or another) resolves the issue.

2 Likes

I would prefer not to add another bloaty software into an already full Moto X.
This was disabled in the past. I’m not sure why or how it turned itself back on and why the option to disable the feed has been removed…frustrating.

Success!!!

Ok, the only way I could find to remove it is to go into the list of all apps and then long-press on the google icon, as if you were going to drag and drop onto your wallpaper, drop it on the “App info” at the top of the screen.

Then click MANAGE SPACE under the Storage section

I then clicked CLEAR LAUNCHER DATA and then approved with a final click on OK and it the google now feed is no longer active on my home-screen “swipe left” feature.
WARNING!>>> this will reset your home-screen layout! all icons, widgets and wallpapers are reset after this “fix” as well as some other settings

starting from scratch, but hey, I no longer have this issue and I didn’t need another App.

1 Like

Swipe into the feed -> Tap the hamburger menu and select options -> Your Feed -> Disable.

For in the future if it reappears.

Sadly that solution doesn’t work on the Moto X 2nd generation. They have removed that method for some reason…

I have the Moto X 2ng Gen, the option was there for me. Quite the pickle.

I was able to remove it by going to settings/apps and disabling the Google app. The phone reverted to the factory installed version. I had also set notifications to OFF for the app. My play store settings will not automatically update anything, so I will leave it unupdated. It disappeared from my home screen. Hopefully it will stay that way. Another benefit is that (disabled) it now only consumes 24KB of storage. My phone is Android 7.0 (Moto G+ 5th gen)

The issue with disabling the Google App is that it not only disables the swipe left, it also disables all the other functions of the app. Your neutering a lot of the useful functions of the phone and might as well have not gotten a Google enabled phone in the first place. But then again, for some, maybe that’s the point.

Yes, I thought about that but so far I haven’t found any essentials that were disabled. I still have my contacts, photos, calendar, maps, messaging, calling, etc. I’m not sure what else that app does, but it was getting very annoying having it constantly trying to give me messages about my commute, dining habits, shopping, news preferences and more. I would just as soon have Google stay out of those parts of my life. It would be nice, though, to get a list of essential functions provided by the app. BTW, my previous Moto G1 did not have that annoying swipe left feature. Instead it gave me 2 more blank wallpaper screens.

1 Like

does not work for Moto E 2nd Gen

THIS actually works. though like you say it did mess up my home screen for a couple minutes. my guess is it will be back before too long, who knows.

I got this one figured out! I have a Moto Gs5 plus. I went to settings, apps, and found Moto App Launcher. Click on that, there is a gear icon, click on that, and an item will come up! Select this line to show nothing on a swipe left and you’re good to go Screenshot_20171201-162103|281x500

Message an
Expert customer