How to prevent switch from Wifi call to Cell call


#1

Hey all,

I happen to live in an area of my town where the cell coverage is not so hot, but my Wifi calls are great. So whenever my phone (Moto G5 plus) switches from Wifi to Cell during a call, the other person only catches bits and pieces of what I say. I set it up to manually handover the call back over to Wifi, but moments later the phone decides that to go back to a cell call.

Is there any way to tell my phone to only make wifi calls? Because this is a huge pain.

Thanks

***UPDATE:
Both of Louisdi suggestions were what I was looking for. No more horrible phone connection calls for me!


#2

The easiest way is to simply put the phone in airplane mode and turn wifi back on, then the phone will have no cellular network to hand off to!

You can also disable handover on that particular network through the Republic App: https://community.republicwireless.com/docs/DOC-1764-republic-wireless-app#jive_content_id_Manage_handover


#3

Louisdi,

Please give yourself a high five, because those are both fantastic suggestions.

Thanks so much.


#4

Actually not so great because it requires a manual action when entering home and another when leaving. Automateit would seem to be the ideal solution but for some reason Automateit cannot turn airplane mode on and off on my MotoX… Can anyone explain why?


#5

No, it doesn’t. Please reread the suggestion:


#6

Google removed access to apps with out root access from controlling the Airplane mode (and cell antennas)
the airplane mode happen in the KitKat OS and the cell antennas was in lollipop
and the Moto X is currently rotatable since the KitKat OS


#7

Louisdi

Thank you for your help.
I did what the Republic pages say I should do.
I have Lollipop
I can force a change from Wifi to cell and back.
BUT if I force it to Wifi it switches back to Cell after a few seconds.
Any suggestions?
Thanks.

Jim

Cell: 321-474-6289


#8

The manual handover is not what I’m referring to. Take a look at the section on disabling handoff and uncheck your home network. This will prevent the WiFi to cell handoff from occurring.


#9

Many thanks. I think I got it.
Jim

Cell: 321-474-6289


#10