How to reboot motog5 plus without power button?

I need help rebooting my moto g 5 plus. The power button stopped working several days ago (just middday randomly) and I figured I could just use the fingerprint scanner to open it/turn it on. My phone died, so I recharged it all the way (100%), but I still can’t turn it on without the power button. I have been able to get to the reboot/recovery screen but I can’t choose any options without the power button. I’ve tried plugging it into my laptop because some people online say that will reboot it. Everything else works on the phone just not the power button. Is this just a problem with these phones?

Any help please?

Sadly, the fingerprint scanner is limited to unlocking one’s phone. It does not and is not intended to be used for power on/off.

You’ve piqued my curiosity. How are you able to get to recovery without use of the power button?

There are apps that can mimic the function of a phone’s power button, however, using them would require the phone to be powered on first. I do not know of another way to power on a powered off phone other than using the power button.

To get to the reboot screen, I held the volume down button and plugged it into my computer at the same time. I need help being able to choose/select options on that screen because I can’t without the power button.

I fully understand the goal. The reality is there is no conventional way and, perhaps, no way at all to power on a powered off phone (or navigate recovery menu options) with a defective power button. You might see if anything here helps:

You might also reach out to Motorola:

https://support.motorola.com/us/en/contactus

You may also need to accept the possibility, short of repairing the power button, what you hope for may not be possible.

still doesn’t work. Does anyone else have any options? Or knows how to fix it/has done it themselves before?
Could I replace the power button?

Hi @awill789 , :slight_smile:

The below link has instructions for selecting options on that screen. You might want to try it and see if it works. :thinking:

The poster says:

If you want to scroll on the options you can use volume down key. You can select an option by using volume up button. (I assume while being on or highlighting the restart phone option)

https://forums.androidcentral.com/showthread.php?t=417443&p=4226114&viewfull=1#post4226114

Thanks, but the volume up button does not work to select on the moto g5 plus. It just scrolls to the next option

I was afraid of that. Thanks for trying! :slight_smile:

Ifixit, (who I would recommend for this kind of repair), does not appear to have parts for your situation. :disappointed:

Your trusty moto g5 + was release early 2017 and has served you well!
Perhaps it is time to look at a new phone with a brand new warranty? :wink:

Even if you can get your g5+ fixed for say… $100, for $49 more you could have a brand new phone.

A new moto g Play from Republic will cost you $149.

1 Like

You might want to consider one of the Power Button reMappers found on Google Play Store, one of these, possibly enabled by the use of a 2nd app such as Air Droid might be solution.

I would consider that, but I can’t even turn my phone on, even with full power

Hi @awill789,

I am able to successfully boot a Moto G5S+ (and a couple of other phones, just for fun) without using the power button, so I’m hopeful this will work for you.

To start, you’ll need a tool on your computer called ADB. Instructions to set it up are here:

You can ignore the first part about enabling developer options on your phone, and just skip to the part about installing ADB on your computer. Follow the appropriate instructions for your computer (Windows/Mac/Linux) until you have successfully opened the command prompt within the platform-tools folder. If you do a directory of that folder, you’ll see an executable file called fastboot, and you’ll know you’re in the right directory.

Next, use a USB-micro data cable to connect your phone to your computer - and hold the volume-down button as you’ve successfully done when connecting to a charger. Just as when you connected to the charger, you’ll continue to hold the volume-down button until the phone boots into the recovery menu. You can then release the volume-down button…

Now, in the command prompt on your computer, within the platform-tools directory of ADB, type:
fastboot reboot
and press enter.

This will send a command to the phone to reboot, and it will reboot normally, not into recovery.

Good luck! :crossed_fingers:

1 Like

Thanks, I sadly have already tried this earlier today and it didn’t work. It said “no devices/emulators found”.

I got it to not say “no devices found” but all the text is red after I type “fastboot reboot” and it says the command doesn’t exist

Are you certain you’re in the platform-tools directory? Do you see the fastboot.exe file listed?

Yes, it just isn’t recognizing the device or any command. I do see the fastboot.exe file listed

Have you made sure the cable is a data cable, not a charging cable?

What kind of computer (PC/Mac/Linux) are you using?

Could you share a screenshot from your computer?

1 Like

I think I need a data cable. Will let you know if it works
thanks!

1 Like

It still says fastboot usage no command


here is a screenshot of what it says

Okay, in that case use
.\fastboot reboot

Message an
Expert customer