How to update firmware on TMobile Samsung S6?

My son is trying to bring his unlocked TMobile Samsung Galaxy S6 to Republic. I know TMobile phones are not a compatible BYOP but other Republic customers have had success (Samsung Galaxy S6 BYOD question ). We have followed the instructions but the firmware update fails at sboot.bin when using ODIN. \

Any ideas??? I’ve listed the phone info, ODIN log info, and what the phone says during the failed attempts below

Model: SM-G920T

Android 6.0.1

Android security patch level March 1, 2017

Baseband G920TUVUSEQC2

Kernal Version 3.10.61-0756325

dpi@SWDD5919 #1

Thu March 23

Build Number: MMB29K.G9TUVUSEQC2 (we know its an unsupported build #)

We have tried flashing the firmware with ODIN unsuccessfully

We’ve tried these build numbers: MMB29K.G920TUES4DPH2 & MMB29K.G920TUES4DPF1

The FRP lock is unlocked

We tried flashing the sboot.bin by itself

We tried flashing the firmware without the sboot.bin. When we tried this it gets stuck at file analysis or ODIN shows message md5 binary is invalid.

Here’s the ODIN log:

<ID:0/004> Added!!

<OSM> Enter CS for MD5..

<OSM> Check MD5.. Do not unplug the cable..

<OSM> Please wait..

<OSM> Checking MD5 finished Sucessfully..

<OSM> Leave CS..

<ID:0/004> Odin engine v(ID:3.1203)..

<ID:0/004> File analysis..

<ID:0/004> SetupConnection..

<ID:0/004> Initialzation..

<ID:0/004> Get PIT for mapping..

<ID:0/004> Firmware update start..

<ID:0/004> SingleDownload.

<ID:0/004> sboot.bin

<ID:0/004> FAIL!

<ID:0/004>

<ID:0/004> Complete(Write) operation failed.

<OSM> All threads completed. (succeed 0 / failed 1)

 

Here's what was on the phone when it failed

ODIN Fail

secure download: enabled

knox warranty void: 0

(0x000)

AP SWREV: B:5 K:3 S:4

SW REV. CHECK FAIL. DEVICE: 5 BINARY: 4

Any ideas???

Hi @joels.cv4uj4

While most of that is over my head, I have experienced something similar with that company (J3). My kid told me he was just trying to load some gaming software, but it bricked the phone.

To make a long story short, it triggered some kind of ‘hack attempt’, which in turn voided the warranty on the phone.

Some nice young gentleman went out of their way at a local BestBuy (Samsung kiosk) and fixed it …much to their surprise as well as mine…

edit: This will be a factor…

joels.cv4uj4 wrote

ODIN Fail

secure download: enabled

knox warranty void: 0

(0x000)

AP SWREV: B:5 K:3 S:4

SW REV. CHECK FAIL. DEVICE: 5 BINARY: 4

Any ideas???

It does not appear to have triggered the knox counter.

sw rev check fail device 5 binary 4 | Samsung Galaxy S6

thanks for the info!

We’re new to the inner workings of smartphones…I posted a similar question on a samsung forum (sammobile.com) and was told that the last 5 digits of build numbers are in alpha/numeric order and since all the Republic builds are older versions that the one on the phone the secure bootloader would prevent older versions to be put on the phone.

Before I explained that to my son he researched which Republic build is the newst and discovered G920TUES5DQB1 came out in March. So he downloaded it, used ODIN to flash it and it worked. The Republic app now says its a suitable phone and to order a sim card.

Another thing we learned - the importance of good, thick USB cables. The first two times of trying to flash the phone with G920TUES5DQB1 we got past the sboot.bin but it would stop at system.img and say Removed (meaning ODIN thought the phone was removed from the computer). We ditched the Samsung cord (most say use the manufacturer’s cord) and used a new thick cord I had. We also plugged the phone into the USB port on the back of the computer (the one directly connected to motherboard) instead of the front USB (we’d read on other forums about that). It worked!

Thanks for the replies and comments.

Message an
Expert customer