Huawei Ascend 5W won't go pass the Huawei logo initial screen upon starting up

My 1-week old Huawei Ascend 5W won’t go pass the Huawei logo initial screen upon starting up. I tried by completely powering off several times, but the phone just won’t complete the rebooting sequence and stays with the Huawei logo in the screen indefinitely. Any clue in how to solve this will be appreciated.

Hi @brauliom.toifof,

Sorry to hear of the difficulties. If your Ascend won’t boot the options are:

  1. Clear the Android System Cache
  2. Factory Reset from Recovery

Thank you. Unfortunately, none of the two methods are working out. Result is the same. When it boots, the Huawei screens remains there indefinitely. Making it worse, the options in the EMUI screen are in Chinese but I navigated the best I could using Google translator. Still, none of these two options are working out. Any other idea, please?

Factory reset from recovery is the last resort. When that doesn’t work, it’s a sign the phone is defective. Since you reference the phone being a week old (which is within Republic’s 14-day money back guarantee window), I suggest raising a help ticket here: Republic Help. Please be certain to mention you’ve tried a factory reset from recovery or reference this thread, so you’re not asked to repeat that which you’ve already tried.

Not certain how your phone decided to change it’s language to Chinese. For what it’s worth (in case Google translator got it wrong) factory reset is the middle option in the EMUI selector screen.

Message an
Expert customer