Huawei Ascend not activating

activation

#1

Hello, I’ve had a Moto E 2nd generation for about a year but I cracked the screen and I wanted a new one. Got the Huawei and it arrived today. I think I was able to transfer my number over but that’s when my new phone started acting weird. I tried installing new apps, like spotify, snapchat, etc, and the Google Play store says already installed, but I can’t find it anywhere on my phone. Also, I tried transferring over my texts and call history but I keep getting a message that I need to activate on Republic Wireless to view them. I thought I already did that but when I go to activate now, I can’t sign in. Sign in just fine on my PC but not only can I not find the RW app on my new phone, it keeps saying wrong password. Any idea what is going on here? I’m thinking I need to cancel/sign out of my old phone, but of course RW doesn’t have a hotline I can call or instructions on how to do this. Help please…


#2

Hi @brodiem.3czxi1,

Please don’t cancel service to your Moto E2! If service hasn’t transferred to your new Huawei Ascend 5W, doing so will make matters worse not better.

As a starting point, if you’re unable to find the Republic app on your new Huawei Ascend 5w, may we know what is asking for a password? Is it a screen that looks like something like this:

If not, may we have more detail?


#3

Yes that’s exactly what it looks like


#4

Hi @brodiem.3czxi1,

That’s the Ascend’s lock screen. Do you recall being asked to input a 4-digit unlock code? I’m afraid if not the only solution is a Factory Reset from recovery. Specifics for the Ascend here: https://community.republicwireless.com/docs/DOC-1953-factory-reset#recoveryhuawei.

You’ll want to be certain to use the same Google (Gmail) account used when originally setting up the Ascend. Also, please do not change the password on that Google account. Doing either will trigger your phone’s so-called kill switch locking you out for at least 72 hours.

Once back into the phone, you’ll need to go through the activation sequence again. A walkthrough here: Activate | Republic Wireless. Detailed guidance here: https://community.republicwireless.com/docs/DOC-2430-activate-my-phone#setupmarshmallow.

If you are able to get past your phone’s lock screen, please advise if you still don’t see the Republic app.


#5

Again, set up pin and connected to google account. Problem is that I get a notification from RW - says you still need to activate your phone. I click on this notification, takes me to the login page. I enter my credentials and it says not correct. This is despite simultaneously logging into my account on phone and computer. Computer works fine.


#6

Would it be possible to post a screenshot of what you see?


#7

Huawei phone still has the same problem. I went ahead and reactivated my old phone - it seems to be working fine and nothings changed there. When I go to the RW account online it ways the Moto E is my phone, no mention of Huawei. Glad I can actually receive calls and texts again but I still want to switch over to my new phone. So basically I’m back at square one. Probably gonna reset the Huawei to factory settings, wipe everything I entered and try again.

Here’s some screenshots of where I am right now.


#8


#9

Thanks for the screenshots. The first thing I note is your phone in running in Safe Mode. The Republic app will not function in Safe Mode. Generally, all one needs to do to get out of Safe Mode is restart the phone. You will, however, need your screen lock password when the phone restarts. If you have that, press and hold the power button, next tap Restart then tap Touch to restart.


#10

And what is safe mode and how do I turn it off?


#11

Ok I got rid of that. However, the invalid SIM card thing keeps popping up. Idk what to do


#12

Oh, just saw that all my apps are back.


#13

Now that you’re out of Safe Mode, does the Republic app still say your SIM card is invalid? If so, I suggest powering down the phone, reseating it then restarting the phone.


#14

brodiem.3czxi1 wrote:

However, the invalid SIM card thing keeps popping up. Idk what to do

Reactivating your E2 likely deactivated the Ascend and you will need a new SIM unless previous suggestions help…


#15

Hi @brodiem.3czxi1,

@williamo.vkbg0s is correct. If you reactivated your E2 as a replacement for your Ascend (moved your number from the Ascend back to the E2) you inadvertantly fried the SIM in the Ascend. It will need to be replaced. You may do so from Republic here: https://republicwireless.com/bring-your-own-phone. Or, from Amazon here: https://www.amazon.com/Republic-Wireless-Starter-Prepaid-Carrier/dp/B01J63NYAO/ref=sr_1_1?ie=UTF8&qid=1476642371&sr=8-1&keywords=republic+wireless.

Sorry, I didn’t pick up on the fact you had reactivated your E2.


#16

Good point. I didn’t want to reactivate my E2 but of course no one mentioned that I had to restart the Huawei an additional time to get out of some Safe Mode I had never heard of. Anyways, if that’s the case what is the process to get a new SIM card?


#17

Ok, that’s in the mail. Idk what screwed it up initially though. It seemed to all work. When I get the new SIM card, how do I tell republic wireless to drop my old phone?


#18

Hi @brodiem.3czxi1,

Once you receive the new SIM, start the Republic app to begin the activation sequence. Republic offers a walkthrough here: https://republicwireless.com/activate. You will be prompted to sign into your Republic account. When presented the opportunity, select “replace existing line”. You should see the phone number you want to replace listed at this step. Continue through the activation process, then you’re all set! The “replace existing line” procedure will transfer the number from your E2 back to the Ascend and simultaneously deactivate your E2.

I wish I was able to shed some light on how your Ascend got into Safe Mode in the first place. Safe Mode is intended as a diagnostic tool to determine if a third party app is causing a conflict leading to poor phone operation. It disables all third party apps, which is why you weren’t able to access them while in Safe Mode.


#19