I'm not receiving calls when not at home by (wifi router)

What phone do you have? SAMSUNG A50

What plan are you on? REPUBLIC WIRELESS GSM

Does your plan include data, or just talk & text?
20 DOLLAR PLAN


Issue Description

I was out for the fourth of July and somebody that was with me but not right by me tried to call me but my phone didn’t ring (they were able to text me somehow though) but get this the minute I got home hours later when I walked in my front door and my phone connected to my Asus wifi router the notification for the phone calls came through.

I don’t get out a whole lot otherwise I assume this would be happening more often (although it has happened when I went to the grocery store too).

So why am I paying for service if it ONLY works when I’m 10 feet from my wifi router? I’m paying for the tower service! And I already pay separate for my wifi service so why am I even paying for RW if it doesn’t work?

Is there a setting (such as wifi preference under wifi calling) or ANY other setting that may help? Although from what I understand wifi preference is for when you are connected to both wifi and the towers so it shouldn’t matter.
I had it set to prefer wifi since I’m home more than I’m not.

Btw I’ve had both a CDMA and now a GSM sim card. The CDMA service was UNusable it was SO awful even though RW told me it would be best in my area and I also had CDMA virgin mobile for years without one issue.

The RW GSM sim seems to work better than the CDMA RW service did but still not great.

Is it just that RW is unreliable? I don’t get why when they are simply using the big networks towers. Could it be the way they implement their service with the app etc?

  • I don’t have your specific Samsung phone, nor can I find a reference to settings that you should check.
  • I would suggest that you look for the following settings and see if any fit what your device provides. Search within your Android Settings is best.
    • Mobile networks
      • Ensure Data Roaming is enabled (no charge, but required for connecting to the network
      • VoLTE should not be enabled (not supported by Republic)
      • Network mode - LTE/3G/2G (auto connect should be selected

Please post back what you found and any changes made, then someone with knowledge of your phone might join in on the discussion

Hi @SDMF,

Candidly, what you describe sounds like a cellular coverage issue. Republic provisions cellular coverage with one of two networks. One network is GSM (T-Mobile network) coverage. The other is CDMA (legacy Sprint network) coverage. If the “big networks towers” in your area are predominately AT&T and/or Verizon, that isn’t going to help your cellular coverage with Republic.

If you’d like us to examine Republic’s cellular coverage in your area, please share a zip code (nothing more).

Meanwhile, you should not be using any WiFi call preferences located in Android settings. With Republic service, Republic’s app handles that. I suggest checking out the following:

3 Likes

The update that @rolandh just provided, is a prime example of how we all learn. I wasn’t aware that the Article by another Community Ambassador @SuperT authored was appropriate. (I honestly didn’t know the A50 was considered a Galaxy phone)

Thanks for the replies. Yes roaming is enabled And network mode is set correctly LTE/3g/2g however I did have volte enabled for some reason, although I assume it can’t negatively affect anything since I’m on GSM rather than CDMA & it’s not supported anyway.

It should be grayed out since it’s not even supported on GSM

YES Please check my coverage if you would? My zip code is 50021, Im just north of Des Moines a few miles. Thanks!

The only WIFI preferences set in Android settings is “wifi calling” with “mobile network” selected in calling preference (preference was previously was set to “wifi”).

There is no way to enable wifi calling without selecting a preference in Android!
There is only 2 options mobile network or wifi

Please clarify the above, my understanding is that you previously had the Android setting set to "wifi’ (which will interfere with Republics WiFi and may be a contributing factor … switching back to cellular)

You don’t have an option, on the screen BEFORE you see cellular preferred to turn the switch for wifi calling completely OFF? While this should normally be left on, turning it off is a good trouble shooting step to see if it has any impact.

That’s not correct. In fact the GSM network is the network where VoLTE is supported. Sprint’s network (CDMA) had little to no VoLTE rolled out before the T-Mobile acquisition.

May I ask what causes you to believe VoLTE is not supported on GSM? VoLTE is indeed supported on GSM. In fact, two of T-Mobile’s (Republic GSM is T-Mobile network coverage) radio frequencies (Bands 12 and 71) require VoLTE. By turning VoLTE off, you may inadvertently be reducing your phone’s coverage footprint.

The above said, GSM (T-Mobile network) coverage in and around the zip you were kind enough to provide is a decidedly mixed bag with large areas of “fair” strength signal. In my experience, “fair” GSM signal strength, at times, might as well be non-existent.

As per the article I pointed you to in my initial reply, you want to turn WiFi calling off in Android settings. I do appreciate it seems counterintuitive, however, with Republic, the Republic app handles WiFi calling and leaving the Android setting on can interfere.

2 Likes

Yes as I said before I had “wifi calling” enabled in android with preference set to wifi preferred but then I switched it to mobile network preferred.
Why would it interfere with RW settings? That makes no sense to me & rather would just confirm the setting.
It seems to me that setting the device to mobile preferred when RW is set to wifi preferred would be conflicting. Also if Im near my router most of the time wouldnt it make sense to have it set to wifi preferred?

CAN SOMEONE PLEASE TELL ME HOW TO “REPLY WITH QUOTE”?
If im gonna reply to everybody or several people im gonna need to quote the person im replying to. Why does this forum have to make it so ■■■■ difficult?

Ive now tried it on my phone and my computer smh

I use my phone 99% of the time. So to use the quote option with your phone, hold your finger on what you want to quote or copy and drag to highlight all you want to include and those options will appear. I’m also using the discourse app. I believe on a computer, this would be accomplished by holding down the left or right mouse button and moving the mouse over the words to highlight. But it looks like you already did this in your reply above to jben.

Republic’s proprietary blended WiFi/cell service is unique (sufficiently unique to be patented). On WiFi, Republic completely bypasses the cellular network. The WiFi calling Android settings are designed to work with traditional cellular networks, which for WiFi calling Republic bypasses. Republic’s WiFi calling is managed by Republic’s mobile app.

Theoretically, leaving WiFi calling enabled in Android settings shouldn’t interfere with Republic’s approach managed by its’ app, however, we’ve seen circumstances where that theory and reality are not the same. So much so that Republic documents turning off WiFi calling on Samsung phones here:

What’s the harm in trying? It can always be turned back on.

1 Like

So to quote someone you just highlight their response? Thats easy enough but the 1st time Ive EVER seen a forum that does it this way, Usually their is seperate “reply” & a “reply w/ quote” buttons but anyway.

Thank you for the link, I did not know that Androids wifi calling feature interferes with the RW apps features. How do they expect us to know this? I really wish they would just figure out how to make them work together properly or at least tell us in the republic app for gods sake!
Now I just have to remember in the future that it needs to be left turned off cause I can guarantee you Im gonna forget and be browsing through my settings and wonder why its turned off & reenable it lol.

With that being said I have no idea if that is even the cause of my issue (prolly not) but good to know. Thank you since RW customer service is practically non existent & they rely on their customers to fix other customers problems for the most part.

Another key to the community ‘Replies’ … there are two types

  1. Reply to a specific comment … bottom right of the comment
  2. Reply to the message tread originator (OP) … Bottom right of the thread
1 Like

I agree it isn’t likely the source of the issue at hand but believe in covering all bases. Earlier in the thread, I inquired about a zip code, which you were kind enough to provide. Based on that, I believe it’s most likely you are experiencing a coverage issue.

Ordinarily, I would suggest you inquire with Republic about alternate coverage. There is, however, an ongoing bug related to that alternative coverage and the Android 11 update just recently deployed by Samsung to its’ Galaxy A50. Your phone may or may not have already received that update. If despite that, you wish to inquire with Republic about alternate coverage, the how to is linked here:

Please note the bug I mention is, for many, rendering their Galaxy A50s unable to make and receive calls or exchange text messages at all when provisioned for CDMA coverage.

1 Like
Message an
Expert customer