In Republic Wireless App, turning off Cell data requests VPN, but OK button doesn't function

apps
#1

In the Republic Wireless App on my Moto e4, when I uncheck the “Cell data” box, a window appears saying “Connection request: Republic Wireless wants to set up a VPN connection that allows it to monitor network traffic. Only accept if you trust the source…” But when I tap OK, there is no response, the window doesn’t move, nothing happens, but the Cancel button works just fine. Is this a RW problem or an Android problem? What’s up?

#2

Hi @jacobb,

A local VPN on the phone only is the means Republic’s 3.0 app uses to lock out cell data to all apps other than those required for Republic’s blended WiFi/cell service to work. Please know the cost of this data is included in the base price of your plan and not deducted from any cell data allowance purchased for Internet connectivity.

So, if I’m understanding correctly, tapping OK doesn’t result in the dialog advising of the VPN going away? Please forgive the screamingly obvious question, however, have you tried simply restarting the phone, then checking the Republic app to see if unchecking the cell data box stuck?

For what it’s worth, I just tested this on a household Moto E4+ and it worked as intended (no restart required). Other than the larger screen and battery, the E4+ and the E4 are essentially the same phone.

2 Likes
#3

So, I’ve restarted the phone several times today, but on the last time, the window’s OK button worked, and the Cell Data turned off. Possibly related: If I’m connected to a Wifi network which does not allow VPNs, would RW’s VPN fail, or is its VPN strictly over the cell network, not over the Wifi?

closed #5

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

Message an
Expert customer