Incoming calls go into Voicemail (calls do not ring) on Moto G3

I have a Moto G3 on the $10 talk & text. Worked fine for last 3 years or more. Then sometime in 2019 I noticed incoming calls would not ring and i would not get a missed call. If the caller left a voicemail though, i immediately got the “bing” and you have voicemail. The caller hears the normal 3-5 rings (20 seconds give or take). After doing everything that made sense and in the Community the problem persists about 70% of the time. Occasionally an inbound call will ring, but i have not found any pattern to what made those calls ring and others not (for instance, I’d have a friend call and it would ring on my end and we’d hangup without answering. Wait 30sec and try again and the call does not ring on my end and goes into VM). Since I am often in areas without Wi-Fi I am really most concerned about this finicky issue on the cellular network.
I have done the following:

  1. Latest RW app
  2. Updated PRL, Profile, and Moto Software
  3. Refreshed RW Activation
  4. Cleared the Moto cache partition
  5. Ring settings is ring only; not set to vibrate
  6. Reset cellular configuration
    Using Android 5.1.1.

Thanks for any help on this frustrating issue.

This almost sounds like the “doze mode” problem?


Since your phone is CDMA, and you have already updated your PRL, I have no suggestions.
I don’t think the Moto G3 can do GSM on R.W. according to the detailed listing of R.W. supported phones?

Maybe some of the experts can chime in for a solution (but it looks like you did a LOT)!

This issues is that Doze mode doesn’t exist on Android 5.1, so that can’t be it. And correct, the G3 is a legacy, CDMA only phone.

1 Like

Hi @davidf.fe4f4c,

I’m sorry to see that no one has offered any suggestions to get this conversation going down a path to resolution!

I notice you said:

Have you isolated the issue to times when the phone is on cell?
Have you noticed if it happens in a specific location or at a specific time of day?
If you’re testing with a friend, do you see any change in your cellular signal strength “bars” as you’re testing? Better yet, open the Settings app and navigate to About Phone > Status > Phone Status and watch the Signal Strength as you’re testing. Do the numbers vary greatly and can you associate those variations with the degree off success that a call will come through?

You’ve done some good initial troubleshooting and a great job of describing what you’re facing. I have to wonder if there has been a change in the cellular environment around you, or if your hardware is starting to show some signs of its age.

A post was split to a new topic: No ringtone sounds

The issue still remains for me. About 95% of time while on cell the phone does not ring. Immediately (<1 sec) after the person leaves a VM (in all trials I did) my VM alert sounds and the message bar displays. No issues ever playing the VM (as in always enough bandwidth). I have not studied in depth the cell strength, but it’s usually about halfway, give or take one bar.

When you say it does not “ring” you also mean that there is nothing on the screen to indicate that you have an incoming call?

Can you confirm that you have nothing set in the Moto App to silence calls in certain situations - when in meetings, while driving, when the phone is face down… and you haven’t added any apps that might offer such features?

You’ve made sure the phone is not in “Do not disturb” mode?

When you try to select a new ringtone, do you hear that ringtone?

I have nothing on the moto app to silence calls. And, not surprisingly, with a G3 i don’t have very many apps at all and all the apps i do have are very standard.

By not ring, i mean there is no ring tone, no message display, nothing on the phone at all. I’ve tried with my phone screen off, screen on at home menu, and with the phone app open. If the caller doesn’t leave a VM, i’d have no way to know i “missed” a call (similar phone app capture as if my phone was shutdown). Of course, if the caller leaves a VM, i hear and see the VM display immediately.

Hi @davidf.fe4f4c,

If these two options don’t solve the issue, I think you’ll need to open a Help ticket.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer