Installing a Non-GooglePlayStore App - Security settings

apps
#1

I am trying to install a weather app, StormEye, from the developer’s site. It is not through GooglePlay. I can’t get it to open due to my phone’s settings. I have attempted to download it over and over, while getting into settings and Unknown Sources (allows installation of apps from unknown sources). However, I download the apk (StormEye.apk). Open, and I receive “Install blocked” msg. Out of Cancel and Settings options at that point, I choose “Settings” and it takes me into the “Security” settings - where I see that I AM allowing installation of apps from unknown sources (the switch is grayed out). How can I get this onto my phone??? Also, I now have 9 StormEye.apk’s in my download group, which is grayed out also, and so I cannot delete the other 8 attempted installs.

How can I get this app onto my phone? What am I NOT doing?

Beverly (albeit frustrated at this point!)

#2

You have to go Under Settings - Security and slide the selector for “Unknown sources” to Allow installation of apps from unknown sources.

#3

I did go back into settings and turned the Unknown Sources setting OFF (grayed out must have been ON). I’ve downloaded the app but STILL cannot get it installed due to security. What security? What do I need to temporarily turn off to install it? :-/

#4

Unknown Sources settings should be set to Green (as you figured out)

I downloaded the APK from the developers site to my PC desktop then used AirDroid: Remote access & File - Android Apps on Google Play …on my phone

Selected ‘App in the Airdroid toolbox’ on the PC (top right of center) and did a drag/drop of the file from my PC download to the Airdroid on the PC. … installed with no problems (this was on my Moto X2)

#5

Hi @beverlyt.thwhfw

Do you know if you have any additional security on the phone? Is there any restrictions such as from a work email or work profile?

As you are saying, the unknown sources option is grayed out so I’m thinking there is something within the system restricting the option.

#6

jben - I am completely mystified. I tried downloading the app to my pc BUT I received a message that Windows 7 can’t open this file. I checked the “Use the Web service to find the correct program.” What I was given was information about changing the .apk to a zip file extension. Is this how you downloaded the app onto your PC or am I somewhat brain dead? :open_mouth: BTW I just installed AirDriod Notification on my pc and according to the software, I should be able to drag or drop the apk to it. How can I do this without being able to get the apk into my pc?

#7

beverlyt, try “Total Commander - file manager” available @ Google Play store(free), been using it for some time and it always work. You don’t open apk. files just move them to your ‘download’ folder on the phone, if you have microSD it’ll work too, in that case you can create an extra folder there for downloads and once the apk. is there find it with Total Commander open it and confirm the installation. You can untick that ‘unknown sources’ permit after that.

#8

happywillow0

I do have es file explorer app loaded, which of course I don’t know anything about - I was simply told it is important to have on my phone. Could this be the security culprit? And since I never use it (although I see there is stuff in it) I can simply uninstall?

#9

ES file explorer became Bloat ware awhile ago I would uninstall it (if a file manager is need I recommed Total commander

#10

To use the Airdroid, here is what works for me (just double checked, cause sometimes I forget I can’t remember everything)

On phone: Install Airdroid and signup for Airdroid. Once signed in you will see a screen with various options for connections. I use the AirDroid Web … it will show visit http://web.airdroid.com or http://192.168.1.xx:8888 (it will be in this form but slightly different depending on your phones connection. I then go to my PC

On PC: type the chosen address into the URL line on the PC a connection widgit that looks like the first screenshot … Then when you Accept it will pop up the Airdroid on your PC screen. I then select the App icon as shown and drag the previously downloaded APK go the spot shown. No need to open the file or anything

#11

jben: What I have done so far: AirDroid is now installed, am using USB connect, and followed AirDroid’s wizard. I typed in the app’s location of https://goo.gl/vcy3cc and entered. When asked if I wanted to update or install, I selected ALL, was given CANCEL or INSTALL - I selected INSTALL and nothing, no response. CANCELED responded. I also uninstalled ES File Explorer. I think I may have to create a ticket at Republic to help me out with this. I have no idea what is stopping the install.

#12

Sorry, I outlined the way that worked for me and re-verified it. I don’t have any exposure to using the usb connection method. The way I outlined only required me to download the APP to my phone and I made no other connection … wish I could be of more help

#13

jben - You did great! I’m the type of person that enjoys having a cell, but knows very little about it. At least ES File is off the phone now! I’m not knowing what security block is keeping me from getting this app into the phone in working order. That remains the frustrating part. I thank everyone for taking part of this discussion. If someone else can suggest a fix, please do!

#14

Cause you keep trying, and I keep learning (what didn’t work) let me give it another try

I just removed the App StormEye previously added

  1. Went to StormEye | Cody D. Smith and downloaded the app to my PC
  2. StormEye (1).apk shows bottom left (PC) the (1) is because this was the 2nd copy of the file I had downloaded
  3. In the URL line (top of same page) … I typed 192.168.1.71:8888 the address that I got when I opened AirDroid (AirDroid Web) on my phone… then did the drag/drop from bottom left of the PC page to the AirDroid tool box … and it installed. This time I did not have the Unknown sources turned on, so I had to follow the screen and enable then continue
    Give it another try and let me know where your results differ in the above step … we can do this
#15

jben - what am I doing wrong? I try to download to my pc Windows 7 and I get the error msg that Windows can’t open this apk file. That’s what started this entire mess. At this point, I don’t know anything. :frowning:

#16

When I download it to my PC (Win7) I do not try to open it … just leave it there and drag/drop to the AirDroid screen

#17

I just reinstalled AirDroid and will try to mirror what you did. I still think there is some security check not allowing the install.

#18

I just re-installed and tested by just dragging it from the Windows Start menu Search (didn’t have to download again)

#19

I see theAairdroid files in the program files, but I’m able to drag the apk file to AirDroid.

#20

Sorry - I’m NOT able to drag the akp file over to the AirDroid icon.

Message an
Expert customer