Internet but no gmail when off WiFi (Moto E 2nd gen)


#1

What phone do you have?

What plan are you on?

Does your plan include data, or just talk & text?

I’m on a plan with data.

Issue Description

The phone worked well for several years. Then several months ago I stopped getting my emails when on cell. I can still open my browser when on cell, anything else - just no gmail. I try to sync (when off WiFi) and get the message “Sync is currently experiencing problems. It will be back shortly.” I’ve gotten the same error message for months. I can get my mail when I’m on WiFi.


#2

There is a possibility that some housekeeping might help clear this up


#3

Thanks, jben. I appreciate your replying, but I have already cleared the cache and freed up space.


#4

ok, then you could try the action after booting into Safe Mode to see if a 3rd party app could be messing with you


#5

Tried safe mode, but still no mail while off WiFi.


#6

ok, my guess the sync of you email is a function of the email client/provider

  • Have you checked to make sure you’re up to date on any fixes provided by them? You may also want to remove/reinstall the email app?
  • What email client are you using? (then perhaps someone else can chime in with some help)

#7

If you set it up as a POP account and you entered the ports yourself, you may have trouble syncing. @haroldw.u68awl Try deleting the email account and setting up again as Other, the app will then chose the best way to setup your account.

If this is a Yahoo email account, you might have more success using a different email app. other than GMail.

Something to keep in mind. If you use a GMail address in GMail app, it will sync every minute or so. If you use an email address that is not GMail it will only sync every 15 minutes. 15 minutes is the quickest you can set the sync time for non-GMail accounts.

Just to add, I suggest clearing system cache. It takes about 20 minutes, will not delete personal information and may give your phone more space to work with:

https://help.republicwireless.com/hc/en-us/articles/115012338967-How-to-Clear-the-Android-System-Cache-on-1-0-and-2-0-Phones


#8

I very much appreciate your help. I agree that it must be a matter of the Gmail app and an incompatibility with my particular phone. I may just have to live with it, frustrating as it is. At least it works when I’m on wifi, so that’s good. Thanks again very much for your time and help.


#9

What if you try to force a sync with the one finger slide from the top while gmail is open?


#10

Good idea, but it didn’t work. Thanks, though


#11

Check in your Republic Wireless App if you have disabled access to Cellular Data for the Gmail app.


#12

No, cell data is “enabled for all installed
apps”.


#13

ok … one last stab. During the heyday of the Legacy phones, I created a Tips & Tricks that provided all of the ‘mandatory’ settings for Moto E1-2/G1-3/X1-2, this was based on following the problems that we were all experiencing, feedback from users and Republic Staff. This is still maintained as Checklist - Phone Info E/G/X CDMA devices not on 'My Choice' 3.0 and if you would ensure that all your Republic App settings and Android settings match there is a chance that might get you going. (make sure you check both)


#14

Thanks for this link. My settings all seem
correct. I still find it odd that it’s only my gmail app that
fails when I’m on cell. Everything else works well. And the
gmail app works when I’m on WiFi. Odd combination. Some upgrade
must have caused the incompatibility.


#15

A couple of solutions that I came across from a brief search on the web
a) Check if you have restricted access to background data for Google Play Services
b) Factory Reset… of course, I wouldn’t recommend it if this is just a minor annoyance.


#16

Sorry -. How do I check Google play services for the possibility you mentioned?


#17

Under Settings -> Data Usage -> App data usage…locate Google Play Services and make sure that background data is enabled


#18

Thanks… I got there and checked. The “restrict background…” Is grayed out. But I very much appreciate your help!


#19

#20

Have you tried accessing your gmail through the chrome browser? Does that work?