Jolly Roger Defender app can't merge two calls

What phone do you have?

Galaxy S7

What plan are you on?
3.0

Does your plan include data, or just talk & text?
Data too.

Issue Description

I’m using the Jolly Roger Defender app, which on a button press during a phone call is suppose to make another call and then merge the two calls together with the existing call. I recently received a call (while connected to WiFi) that I wanted to conference in a “pirate” bot via the Jolly Roger app. When I pressed the “add a Pirate” button, the Jolly Roger app placed the first call on hold, made the second call, but on merging the calls I received the attached error. There were not other applications running at the time and nothing trying to make a recording or use the microphone.

I tried multiple times and always received the same error message.

It work once in the past, but that might have been with WiFi off.

I found this article: Error: "Another Application Is Currently Using Your Microphone" – Republic Help

I verified that the Repulic Wireless app already had mircophone permission. The Jolly Roger Defender app does not have microphone permission, but does have phone permission.

Any ideas what went wrong?

Thank you for your assistance.

Sincerely,
Stephen

Screenshot of the error:
image

Hi @stephenm!

It would appear that the Galaxy S7 and S7 Edge don’t support three-way calling on Republic. I know because I tried to do it on an S7 Edge last year. It would connect for a few seconds and then I would receive the error you received.

A couple of things that may help you sort this out

  • Does this fail on Cell, WiFi or Both?
  • A brief look at their site, I note they have quite a bit of information around Google Fi, you may want to review
  • Don’t forget that our Republic Wireless phones all utilize two separate phone numbers, and on some model of phones determining the hidden/underlying number is not obtainable and/or often changes.
  • Have you posed the question to Jolly Roger?

btw … I hope the 512 (Austin, TX) party you called doesn’t mind you publishing their number :slight_smile:

1 Like

Hi @jben,

  • It only happens on WiFi. Indeed, I remove the Jolly Roger Defender and the problem persisted using the stock dialer/phone apps, but again only on WiFi.
  • Google Fi operates like a VOIP device, so they can do SIP intergration. Republic Wireless does not support that. (Also know as Simultaneous Ring.)
  • Could be related to the problem.
  • Yes, but since the problem exists without their app, I’m pretty sure it’s a Republic Wireless problem.
  • That is an incoming spam number… spoofed for sure. No idea who actually owns that number, but it is probably good someone trimmed it out.

Thanks for your reply.

Hi @mb2x,

Interesting that you have the same/similar problem. It works for me if I’m on the cellular network, but not of WiFi. Tried after removing the Jolly Roger Defender app and the problem is the same.

What software/firmware level are you running? I’m at the latest Republic Wireless app, but pretty back-level on OS, as I’m not sure I’ve ever had a positive experience with OTA OS updates. Plenty of negative experiences - mostly making default apps perform/function worse than before.

I’m running: G930UUEU4BQD2. (April 1st, 2017 security patch - good thing I don’t have anything important on my phone)

Hi @stephenm!

I don’t have the phone anymore. I gave it away to a friend. I was on the latest update (to my knowledge) when I tried (March of last year). That’s definitely odd behavior though.

When I tested it, I was on Wi-Fi, but since it has worked for you on cellular, it must be an limitation or issue with Wi-Fi 3-way calling on the S7 phones.

Hi @mb2x,
If it is a limitation, okay. But it would be nice if Republic Wireless support would admit it. I’m running a ticket with them and so far I’m just getting the run around. Typical, saddly.

Hi @stephenm!

I know that other phones are capable of three-way calling on Wi-Fi (I tested the Moto X Pure and it worked on Wi-Fi). Additionally, a number of Ambassadors and Experts tested a number of devices for three-way calling last year.

I wish I could be more helpful with you, but three-way calling is something that I don’t know much about other than the two phones I tested it on. In fact, I didn’t know it was a thing until last year. There’s not much documentation on it as it varies from phone to phone (some support three or more, some don’t). Regarding the S7, whether it’s a bug or some limitation, I don’t know. I am inclined to think that it’s some sort of bug since it works on cellular but not Wi-Fi, but that’s pure speculation. Hopefully those working with you in the support ticket can explain it!

In either case, please let us know what happens as I am curious about this too!

1 Like

Normally we don’t see Republic Wireless support engaging in what you classify as ‘getting the run around’. Most often it can be considered as lack of understand from one or both sides.

  • Have you considered the following:
  • Remove the Jolly Roger Apk from your phone
    • Do a Factory Reset, with restoring anything (apps etc) from the cloud
    • Update your OS, to pick up any of the Manufactures security patches that they have made available
  • Then try the merge two calls, testing both WiFi and Cell
    • If the merge still fails, then update the Open Ticket with what you did, failing scenario and results
    • If the merge doesn’t fail, than add back the Jolly Roger code, test and if the failure return work it out with the Jolly Roger folks
2 Likes

Wow, @jben, I consider that possible solutions pretty extreme and I’ll explain why:

  • I don’t have my aps and such backed up in the cloud (and don’t really want them there), so a factory reset really sets me back and could result in a lot of lost things I care about. You might disagree with me not backing them up in the cloud, but I’m willing to accept the risk (I do back up otherways, but they are not going to make restoring easy). I’m not willing to nuke everything from orbit.
  • Every single OS update has made things worse in my experience. I’d really rather not go down that route, although it is less extreme than a factory reset.

I’ve already deleted the Jolly Roger app and looking through my tickets, I originally report this problem to Republic Wireless 2 or 3 years ago. Got the run around then as now. Glad you have had a better experience with their support personel. I just had to resend something to them, because one of their employees literally didn’t read what I wrote. I told him I uninstalled the Jolly Roger app and he went on to complain that it must be the fault of the Jolly Roger app - that is no longer installed… literacy… sigh

Ok, I understand your concerns on the Factory Reset, and I would only recommend it as a last ditch effort. Unfortunately if something in ther core OS has been corrupted, the usual recovery is delete the RW app and re-install… nothing lost. Then a Factory Reset, this is of course assuming you have already done a clear cache which I suspect support has already called out.
Sorry I can’t be of any real help, but good luck and please post back whatever the final resolution is, it’s how we learn and pass it on to the next person

3 Likes

Hi @stephenm,

The ability to merge calls on Wi-Fi is a known issue for Republic Wireless calls with Samsung phones. I will make sure the Help Team is aware of this limitation. I apologize that they were not aware and have tried to troubleshoot the issue with you.

I will try to make it a point to make sure the Help Team is aware of known issues when we launch new phones.

It may be possible to hand the call over to cell, then merge the calls. Have you given that a try?

3 Likes

Hello @southpaw,

Thank you for the update. I’ve not tried to hand the call over to cell and then merge. For the purpose of the JollyRoger Defender (merge in a robot with a scammer), that may be too time consuming, but it is worth a try.

Thank you for your help.

Sincerely,
Stephen

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer