Last System Update

What phone do you have? Moto G6, new in April 2019

What plan are you on? My Choice +1 GB

Does your plan include data, or just talk & text? Data, talk and Text.


I have an Amazon Echo in my kitchen, which I have successfully paired via blue tooth to my phone. I primarily pair them to listen to music or audiobooks. This worked very well, with no problems until the most recent System update. My phone now connects with no issue, but the connection via blue tooth is horrible. It skips, disconnects, and is not useable. The phone does not seem to have this issue connecting with any other blue tooth devices. I have tried to disconnect and reconnect, forget and repair device, and everything else I can think of. The issue began just after the update. Anyone have ideas?

Issue Description

I’ve found one other similar post on the Motorola forums. The suggested remedy was to unpair all of the devices on the echo dot and just pair it with the Moto G6. The OP never replied:

Hi- I have tried that as well, and had no success. Again, it worked fine when I went to bed. Updated my phone when I got up, and now it does not work. Literally, nothing else changed but the update!!

You might try contacting the company responsible for the update:

https://support.motorola.com/us/en/contactus

I would take a look at the app that you use for streaming the content…and see if another app works any better or different than your experience with the current app.

Hi- thanks for the reply. It’s the same for every app I use, only connected to Echo. When I connect to other devices (i.e. headphones, sound bar, portable speaker) it’s fine. And yes, I have deleted all these devices from my phone, and re-paired with the Echo only. Same problem.

Are there other bluetooth devices connected to your Echo?

My Samsung TV…randomly started searching for nearby bluetooth devices in the past week.

No, I deleted all other devices paired to my Echo. (on that note, I also have paired other devices to my Echo, they worked just fine. It is just my Moto G6, and just since the update.)

I wonder if a reset of your Echo might help.

Also, a firmware update of the Echo… is another option.

I agree that none of these steps should be required after a simple device update…but just looking at options that might kick it out of this state.

1 Like

I somehow fixed the problem. Since the update, there were “ghost” paired devices on my phone. It literally showed two devices paired, but all the information about the devices was blank. It looked like my phone was duplicating blue tooth devices, but not fully paring any of them? I deleted all the paired devices on my phone, reset the Echo, deleted all the paired devices on my Echo, and repaired the devices. Some combination of all this worked! Thanks for all of the suggestions! I appreciate the help! (The PRIMARY reason we purchased the Echo for my kitchen, was for the Bluetooth speaker!!! So, I was very frustrated that this wasn’t working!!!)

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer