Listening to messages; primary SIM

I just replaced my old phone with a Galaxy A42 5G

Yearly plan

Plan includes data, talk, text


Issue Description

PROBLEM: I am unable to listen to messages.
Popup Msg:
To listen to this voicemail, make SIM card your primary SIM

The phone arrived yesterday with SIM card installed. I also started receiving this message on my old phone after an Android update (prior to phone dying and the update, I could retrieve VMs with no problem). Advice much needed ASAP.

NOTE: I just submitted a Help ticket.

Hi @didak.qblqpl,

I’ll admit to operating at something of a disadvantage in that I don’t have access to a Samsung Galaxy A42 5G or other 2021 Galaxy A-series phone.

Having said that and understanding the SIM was installed by Republic; have you tried opening the SIM tray? I believe the Galaxy A42 5G is a dual SIM phone and it’s possible the SIM was installed in the wrong SIM slot. Republic service requires its SIM be installed in SIM slot 1.

The voicemail issue aside, is Republic service otherwise working as expected on your new Galaxy A42 5G?

Hi @didak.qblqpl,

I’ve seen this pop up once on my Samsung S21+, and my Pop had it appear on his Samsung S20 FE, but in both cases, it cleared up on its own.

Was your old phone also a Samsung?

Are you able to listen to your voicemail despite the message on your new phone?

Have you tried to refresh the Republic Activation?

I opened the tray and saw only 1 SIM tray, containing the SIM.

Service otherwise works but unable to listen to VM.

My old phone was also a Samsung. I will try refreshing activation.

I conducted refresh activation and the problem remains! I have also turned phone off and on multiple times today since discovering the problem (which I previously thought was just a function of my old messed up Samsung!).

Fwiw, the same thing happens with my samsung s21 about half the time when I try to access voicemail messages from the phone menu but I can always get messages by calling voicemail.

Hi-- yep. seems to be a known bug with some Samsung phones. I was in the habit of using visual VM but will now be calling in. I was advised via a Help ticket to refresh activation, but that didn’t work.

Here’s what I’ve found works:

  1. Uninstall the Republic App
  2. Reboot the Phone
  3. Reinstall the Republic App

Did that too with no effect!

Im seeing this too., also getting all my pics in text messages rejected

I am also getting this message with my new Galaxy s20 fe. It wont let me listen to vm unless I call in.

On my Galaxy Note 20 when I check for a VM (using the green Samsung dialer app). I start in “Recents” and tap on the VM I want to listen to. I can tap anywhere in the red box I marked on top.

It will open up to:

Tapping on the the “i” icon brings me to this screen:

THIS is where I can have the SIM message pop up :face_with_raised_eyebrow:
If I touch anywhere but RIGHT ON that little triangle (play icon) it will bring me to the call history screen. Clicking on the play icon here always pops up the SIM error message.

But If I carefully click on the play icon (on the prior screen, not the history screen) it will expand to let me play the VM:

1 Like

I have tried the exact technique of carefully clicking the play icon. And it will play a little, then the SIM message pops up again! So I am just calling in now. Much less frustration.

Yes, that did work on my phone. Thank you SuperT

1 Like

The tip from Super T works sometimes. But this is unacceptable. didak.qblqpl, did you receive a satisfactory response from Republic?

No, Republic Wireless provided numerous links, none of which fixed the problem. It’s a known issue with the Galaxy 10, and now apparently with the 42.
Dida

Hi @maryb.xmay6q and welcome to the Community!

For what it’s worth, @SuperT’s method works for me 100% of the time.

I’ll grant it’s not ideal.

It’s unclear, to me, if this is a Republic issue per se or rather a Samsung issue. I can tell you that using an alternative provider’s (Tello) SIM, visual voicemail doesn’t work at all on either a Samsung Galaxy A20 or Galaxy Note20.

1 Like

I had this exact problem today for the first time. I was at home at the time. I went in to work and tried again and had no problems listening to the same messages it had told me I couldn’t without making my sim primary. Don’t know what fixed it, maybe changing wifi networks. That was the only thing. I did not reboot my phone or anything.

Message an
Expert customer