Lose calls on wifi

What phone do you have? Pixel 3a

What plan are you on? 1 GB talk and text

Does your plan include data, or just talk & text? Includes data

Is there an explanation why frequently my phone call will be terminated after about 5 minutes when it’s connected to my wifi but it doesn’t do this when on cell. I’m tempted to only use cell unless I need wifi in certain areas because I hardly use data and never come close to using 1 Gb in a month.

  • Is this at a single location, like home?

I think it’s just at home. It may be my router, but I don’t know how to adjust the settings to correct this problem. It doesn’t occur all the time, but (often) at times when one doesn’t want to be terminated!

Thanks for the feedback, based on feedback from other users I maintain a Tips & Tricks that tries to address WiFi problems.

1 Like

OK. I’ll try that. I have a Tenda on 5g band

ok, relying solely on the 5Ghz band could be the problem, 5Ghz provides speed but the ability to pass through walls/furniture etc is very limited.
You may want to consider activating both 2.4Ghz & 5Ghz and let the phone negotiate with the router to pick the best signal available.

Thanks. I’ll work through this as I am able. Right now I have some things to do more urgently. I appreciate your help and will try to resolve this.


Hi @joelp.2cb6xy,

Have you been able to configure your router so calls don’t drop at the 5-minute mark?

Hello. Thanks for your interest. I looked through the wifi tweaks but nothing that was there was identifiable on my router. So all I did was to do the complete restart of the modem, router, and phone, but I can’t say if it has helped or not.
When I had any problem, I usually just disconnected from wifi and that always eliminates it.
I can see if being on wifi is helped by doing this, but my daughter, in particular, always complains about the call quality when I’m on wifi, so I often just switch over.

1 Like

Did you check to ensure that the router is configured to use both bands (2.4/5Ghz)… this is the Tenda step by step procedure I provided earlier, W15E-How to setup 5G-Tenda-All For Better NetWorking
I always appreciate feedback, as I really don’t like to put out bum dope :slight_smile:

Again, thanks for your help.
I went through the link that you sent but all I can say is that my pages on router settings are nothing like yours so we must be working with different Tenda routers, and my encryption settings are WPA/WPA2-PSK. It doesn’t allow me to set 5G priority, but both 2.4G and 5G are configured to actively operate.
My router is a Tenda AC1200.

Unfortunately they have about 6 AC1200 (this actually is the total throughput 2.4 & 5 Ghz)
Here is a link to find which one you have how to find the product model on the device-Tenda India

For the past month or so I’ve had a similar experience with dropped calls. The Republic app determines my WIFI connection inadequate for voice calls and switches my call to the marginal cell service at my home. The call drops when the cell service drops. I get around this by using Extend home or Duo for calls. I know its not my Wi Fi because Duo calls from my Samsung phone work perfectly.

My Tenda AC1200 is Model AC6 and here is the link to the manual: https://down.tendacn.com/uploadfile/AC6/AC6_User%20Guide.zip
I went through it but didn’t see settings to prioritize 5G or do any of those things.

Unable to connect with Tenda support via the 800 number published in their website. Have left them voicemail.

  • I am guessing that your current SSID (network name) is different for 2.4 and 5? If so have you tried to configure them the same and let the router code sort it? This is what I would suggest at this point.

Thanks once again. You persevere in a problem and I appreciate it very much.
I’ve done that now and we can see what results.
Great helper and problem solver!

1 Like
  • As near as I can tell the router is about 5 years old, so you may want to make sure that the firmware is at the latest level (See page79 in the manual you provided me the link for how-to instructions)
  • The router apparently supports Beamforming, and this can be enabled (See P39), this will allow the router to maximize the connection to any of the newer phones (no change needed on the phone) … beamforming is like the radio in the router pointing a ‘finger’ at your phone

ps: This is considered fun for me :wink:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer