Losing signal with new phone

What phone do you have? Moto 4g play

What plan are you on? smart choice

Does your plan include data, or just talk & text?
Yes


Issue Description

ever since I got my new phone I've had less cell service. Where I used to have service I don't anymore. I was around 3 different people with no service but they had full bars. It's getting frustrating!

What was your old phone model?
If it was one of the Legacy phones on the refund plan, those use the CDMA Sprint network partner. The newer phone mostly use the GSM partner Tmobile.

Please open the RW app, under the settings option what does it say for SIM Type ?

Also, could you proved the zip codes to these locations where u did not have cell service?

It was the Moto 3 gplay that I had. 44805, 44906 and several more I don’t know. SIMS-GSM

43028 is another zip code I had no service

The explanation is fairly simple, the old phone was on the Sprint network, the new one is on T-Mobile and you happen to be in an area where Sprint is better than T-Mobile. Is the phone you’re using now the G4 Play mentioned at the top? If so, you can ask support to move you back to Sprint coverage by following the directions here: How to Request a 3.0 CDMA SIM Card – Republic Help

Oh, and welcome to the community!

3 Likes

Yes I have the g4 now. Thank you for the explanation on this issue. Will LG to link that you mentioned.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer