Mac to Android file transfer

#1

I just got a Pixel through BYOP and am having trouble transferring files I’ve backed up on my MacBook Air to the new phone. When I fire up Android File Transfer I keep getting an error (see pic below) that says it cannot access the phone because the screen is locked (it’s not locked). I also am getting the pinwheel working cursor as it hangs. I didn’t have this same problem backing up my old Moto X files to the laptop in the first place.

Any ideas on how to get this working?

0 Likes

#2

Hi @neuroboy

Have you tried “unlocking” (swipe up) the phone to the home screen and then plugging it in? I know in Windows there can be a message on the phone that asks if you want to allow it to access your phone. Although, I am not certain it dies the same with Mac, I would check for a notification after plugging it in.

mb2x

0 Likes

#3

Thanks @mb2x, It’s a good suggestion. I definitely unlock the phone (and extend to 30 minutes of inactivity before it goes back to sleep) then get the notification when I plug it in asking if I want to just charge or also allow file transfer. I select file transfer and then the folders pop up in the Android File Transfer window on my laptop. It’s stable for less than a minute and then the pinwheel starts spinning and I get the error. One time I was able to get a few files transferred over before the error appeared and I had to start over.

Not sure if it’s related, but, on the Moto X, there was a check-box in the Storage settings (Settings>>Storage>>three-dot menu>>USB computer connect) to permanently allow file transfers. On this new Android build on the Pixel that check-box isn’t available and the decision to only charge or also allow file transfer seems to be something you have to re-select (via radio button) when you acknowledge the notification of connect each time you connect the device to a computer.

0 Likes

#4

Oh dear. I don’t have access to a Mac and have never plugged my Moto X2 into one so I won’t be able to try anything. I think @rolandh has a Mac. He may be able to help further.

0 Likes

#5

Have you tried a different cable?

0 Likes

#6

Good Morning @neuroboy,

@mb2x is correct, I do indeed have a Mac. The dialog you posted is something I see if I forget to unlock my Androids’ screen before plugging into my Mac. I also see it when the phones’ USB settings are set to something other than USB file transfer.

What I lack is a Pixel to test with. If someone would be kind enough to send me one to play with, I’d be most appreciative! :stuck_out_tongue_winking_eye:

On the one household phone running Nougat (an Alcatel A30) the USB file transfer setting persists, so all that’s required is plugging it in to my Mac. Android File Transfer then launches and I’m able to see the phone’s contents.

Most other household Androids’ are still running Marshmallow. For those, the process goes something like this:

  1. Plug phone into Mac.
  2. Android File Transfer launches presenting the dialog about being unable to access device storage.
  3. Close Android File Transfer by clicking OK.
  4. Swipe down from the top of the phone to present notifications.
  5. Tap USB for Charging, then change to file transfer (MTP).
  6. Android File Transfer launches again and I’m able to see the phone’s contents.

I’m familiar with the setting you reference on your Moto X but that setting seems to have disappeared on Marshmallow and isn’t present on my only Nougat phone either. Your Moto X would still be on Lollipop.

None of the above directly addresses the experience with your Pixel, however, I hope it’s somewhat helpful.

2 Likes

closed #8

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

0 Likes

Message an
Expert customer