Managing Doze Mode - (phone is on WiFi) calls via cell | calls go to voicemail | calls are missed

Excellent, please keep me posted (and include which phone type you have)

@jben,
G5+.

I leave it on the table all night, then call it the next morning. So far, 2/2. I will test for a few more nights.

Wish I knew what Moto"s doze timeout is.

It can vary, as a non-developer it is difficult to get a full understanding of the Google documentation on Doze, but I think that it starts out a ‘A’ then keeps expanding as time goes by, that is why I went to the routine that looks for the Notification from RW ‘On Cell’ as the trigger. I have seen mention in the web reading that some devices go into doze as soon as 9 mins of idle time.s

I just added a constraint to prevent the macro from running if the screen is on. I’m covering the case where the macro could trigger while the phone is in its 5-minute window before it sleeps.

I think this makes sense…I think…!

2 Likes

having the missed call issue - I used macdroid on 2 phones prior to my pixel 3 and it seemed to fix the issue - however I dont not remember this disclaimer

nobody else thinks thats pretty sketchy?

I remember seeing that. I thought about it for a while before concluding that in order for all of it’s features to work it had to have this level of control.

3 Likes

I echo @billg’s response and personally just think that is a responsible disclaimer recently provided by the author who is the sole owner, maintainer. To me this is not threatening, and he has provided the ability to allow/deny at your discretion.

  • I currently have a Moto X on Pie 9.0 and it provides very granular control over permissions in Settings / Apps & notifications / Advanced / App permissions, you can view what app has what permission, and if you have a concern perhaps you can limit at the OS level
3 Likes

I have a pixel 3 running android 10 and tried the macrdroid trick to turn on the screen every 50 minutes (worked for me in the past) and the doze detect and neither worked for keeping my wifi from going into standby

unless anybody has something else to try Im going to try keeping my phone in airplane mode when Im home and see if that works

As various levels of Android have changed Doze timings, the 50 min turn on of the screen may not work.

  • I would suggest that you download the latest version 0.9.6 which is documented at the beginning of this discussion, then if it doesn’t ‘fix’ the problem I can try to make alterations based on your feedback and the logs that it keeps. (this is how we got to this point)
2 Likes

@billg I just started to use Dose template on my Pixel 3 XL. While at home on WiFi, it does work to keep cell on, buts that’s all. I get the message that I won’t receive texts or voicemail. Since I have Home Extend, I’m not concerned with not receiving calls over Pixel. I am concerned about getting my texts on time though.

Also, when I try to get into my phone, I unlock it and then the screen goes black. Have to unlock it a second time to get into the phone.

Did not have this issue with everything going into a deep doze since upgrading to Android 10. Now texts and voicemail are delayed until I unlock the phone.

I’m stuck on Android 9 with my Galaxy S8 so I can’t duplicate your findiing. The combination of Extend Home for calls and Republic Anywhere for messaging has completely solved my Doze issue.

For me this might be temporary because RW is no longer developing Republic Anywhere. Recently I opened a ticket about a problem with Anywhere and was told to use Google Messages for web instead. Unlike Anywhere, Google Messages for web requires a functional phone with service. It is of no value to a person whose phone is out of service.

Not having a Pixel 3 XL, and only on 9.0 with my Moto X4 I am unable to do much troubleshooting. If you are using the 0.9.6 version that I have uploaded to MacroDroid it does contain some logs that may provide a clue.
Access Logs from the main menu of MD :menu: top left / User Log

With Android 10, at least on a Pixel, Doze is more like putting the phone into a coma. So far Anywhere still works on my computer, but I’m not always on the computer when at home. So I end up checking my phone every few hours.

1 Like

Thank I did do that and sent them to @billg

I read your logs and wow, that is disappointing. Putting your phone in a coma was a good description.

I just found an interesting feature in Android 10.

Apps & Notifications
Advanced
Screen Time/Notifications recieved/Times opened
Show All Apps
Find RW App and tap on hour glass icon to the far right
Set timer for 23 hours 55 minutes. I’m hoping this will allow RW and Messages to stay alive and not be put into a coma. I’ll let you know if I see improvement.

Just received a small Android update, hoping it’s a bug fix.

2 Likes

I made the tweaks to screen time for RW and Messages, this was no improvement with Doze inactive or active.

Next step, I made a change to Doze. After second Log Event I changed Screen Off to Screen On. So far I’ve received texts on time and WiFi is staying on. Screen will naturally turn off on it’s own. This has also taken care of having to enter password twice to get the phone to unlock.

Since making the change to Doze the log shows that WiFi is on. I’ll report back later in the evening to see if this continues to work after a few hours of inactivity.

3 Likes

Nice work!

1 Like

It works! Have the phone sitting next to me and watched it.

Screen is dark
Screen turns on, arc is hollow
Arc goes solid, screen turns off.
Problem solved!

Correction: I shouldn’t say problem solved, but problem improved. It’s not fool proof. There were a few times when the phone would not regain WiFi. But this is a major improvement from what it was before.

4 Likes

@littletoucan

Here’s what we have been using successfully with our 2 Moto G6’s for a couple of weeks now. Wanted to test in a few more locations before posting. Sounds like you have done something similar by replacing the screen off in ver 0.9.6. We went with a very simple macro (explained below).

We have fair cell and good WiFi at home but SO will often get a single ring and then call goes to voicemail when the phone sits for a long time. Person calling hears 6-7 rings before going to voicemail. I also use Google Messages on my laptop and operation is intermittent (app doesn’t connect reliably) with my phone. Also have the problem where WiFi disconnects in Doze which, in turn, causes the phone to use cellular data (LTE service is available) while connected to WiFi. A couple of Play Store app updates used cell data while connected to WiFi even with Play Store set to update on WiFi only. Did not expect app updates to use cell data. Looks like Doze causes all these problems by being so aggressive about shutting WiFi off on the phones. The good news….using a MacroDroid macro appears to solve these problems.

Here’s the macro we are using on our Moto G6’s running PIE. We based our KISS 30 design on @billg “wait 50” simple macro but it has a few changes because of some problems we had with that version.

TRIGGERS - Using a regular interval of 30 minute as a starting point. Had a few times where Doze shut WiFi off using 50 minute interval. Hope Google’s AI doesn’t start turning Doze on (WiFi off) in an even shorter time cycle. Pardon the pun….but time will tell.

UPDATED TRIGGER INFORMATION - 10/14/2019 (SEE DETAILS AT END OF POST)

ACTIONS - Originally used a screen on followed by a screen off but the screen off seemed to make the “Approach to wake up” feature in Moto Peek Display unstable. Others have also had problems with lock screens. Just turning the lock screen on and then letting it turn off automatically seems to cure the issue. The lock screen only stays on for about 15 seconds. Once you unlock the phone the screen stays on for the time you set in the Android sleep setting.

CONSTRAINTS

“Not in Call” – allows the macro to turn the screen on only when the phone is not in a call. This makes sure the macro does not cause any changes to the normal screen on/off actions when on a call.

“Power Disconnected” – allows the macro to turn the screen on only when the phone is disconnected from external power. Or said another way, the screen does not turn on if phone is plugged into a charger. This is handy when phone is charging on the nightstand next to your bed at night. My understanding is Doze does not turn WiFi off if phone is plugged into charger so there is no need to trigger screen on (which keeps WiFi on) when charging.

ADVANTAGES – Easy to see macro operation without even looking at the MacroDroid system log. Macro triggers screen on, lock screen turns on and you see notifications and WiFi status on screen, screen times out and turns off. Our version runs on the hour and the half-hour. MacroDroid uses about 2% of battery in a 72 hour period.

Love the KISS approach because you’re basically just hitting the power switch every 30 minutes. There is no impact if you toggle Airplane Mode on/off or anything else we’ve tested so far. Should work great for us in Mexico where we have WiFi only (no cell). Turn Airplane Mode on, turn WiFi on and connect to network and we’re good to go. For extra battery life while on a long flight we can turn off MacroDroid using the apps slider and turn on Airplane mode.

Some may say TL;DR but wanted to share the details and our reasoning. Seems like some of the past background discussion was changed when the MacroDroid thread was trimmed. Figure anyone who reads this thread is technically adept and might appreciate the details. Know there are also some MacroDroid experts in the Community so they might even point out something we’ve overlooked or misstated!

My thanks to @jben and @billg and everyone else who have shared their work on the Doze issue. Helped me get a better understanding of the macro operation.

UPDATED TRIGGER INFORMATION – 10/14/2019

We noticed that after the v4.9.1.3 app update the macro stopped triggering reliably on the hour and half-hour. System log showed there were times nothing would trigger for an hour or more and/or macro would trigger at odd minutes. We had made no changes to either phone other than normal Play Store app updates.

We wrote to the developer and asked if there were any changes in the update that would cause erratic trigger timing? To our delight they answered very quickly –

“The only significant change was the SDK of Android they have to target. Each version of Android is gradually crippling background apps so this is the most likely cause.

Please try using the alarm option on the trigger.”

We saw the “Use alarm” option on the Regular Interval configuration page of the trigger but did not use it in the original macro. The original macro appeared to trigger reliably every 30 minutes so we thought nothing about the alarm setting.

Turns out checking the “Use alarm” option makes all the difference in the world. The macro now triggers reliably every 30 minutes again!

Here’s a screen capture showing the “Use alarm” option for anyone who might need to make the same change.

ONE DOWNSIDE TO USING ALARM SETTING – there is now a persistent alarm icon on the notification bar. Not so bad; we use it as a quick way to see the next scheduled trigger time for the macro. Swipe down twice and the next trigger time (alarm) shows at the top of the display. This will be the next scheduled trigger time with no other alarms set.

Alarm%20Icon%20-%20cropped

We will also monitor the battery usage and make sure this change does not cause increased battery usage.

Hope this helps anyone trying to use the KISS 30 Macro.

5 Likes
Message an
Expert customer