Messages app notification sound is the default instead of what I set in the app


#1

What phone do you have? Moto G5 plus
What plan are you on? My Choice 1Gb
Does your plan include data, or just talk & text? Includes data

A week or two ago there was a system update. Since then, the text messages app (the standard one that comes with the phone , Google I think) will not play the sound that I set in the app. Instead the default notification sound plays. Is this a known problem? Is there a work around?

Thanks Mike


#2

Just tested the custom sound setting in my Messages app on my G5 and it appears to be working fine.


#3

Try changing it from what you have to default, then test and return it to what you want … I sort of remember that was the fix once


#4

Hi @michaels.axr76c,

The Messaging :messaging: app that comes installed on the phone is no longer supported. If that’s what you’re using, I’d suggest trying the Messages by Google :messages: app instead.

Have you tried resetting the notification sound as @jben suggested, or or rebooting the phone?


#5

I guess I miss-spoke, it is the Messages by Google app that I’m using.

I did try resetting the notification sound. Set it to default (Talitha) then restarted the phone. Set it to Adara, then restarted the phone. Makes the correct sound when I set it, but when a message comes in it is still Talitha, which is the default. It used to work correctly before the most recent system update.

Mike


#6

Hi @michaels.axr76c,

Settings for a custom notification tone are located in the Messages by Google app itself. I don’t have access to a Moto G5 Plus however, here’s the path on a Moto G6 Play:

  1. Open Messages by Google.
  2. Tap Menu (three dots upper right).
  3. Tap Settings.
  4. Tap Notifications.
  5. Tap Sound.
  6. Make your selection.

My apologies if you’ve already tried this.


#7

@rolandh
I did try that several times. Now for whatever reason I noticed this morning the correct notification sound is working. I would have sworn last night it wasn’t. So I guess it is fixed, probably setting to default and back combined with restarting did it.

Thanks all for the help

Mike


#8

I’m a bottom line guy. So long as it’s fixed for you and stays fixed that’s the bottom line.

You’re most welcome!


#9

So the saga isn’t all resolved. Some messages generate the notification that I set, but many generate the system default. In addition it vibrates with the default sound.
I don’t know how to go about debugging this. If I send myself a text from email, I get my custom notification sound. I’m pretty sure that when I first started trying to fix this other message threads also used the custom sound. Now those are back to the default sound. Not sure if any are using the custom sound anymore or not.

Anybody have thoughts on how to debug this? I’m pretty sure it started with the most recent system update, in the last few weeks anyway. Worked perfectly fine before that.
Mike


#10

Mike,
I just unmarked this a ‘fixed’ based on your last update.
As far as steps to move this forward, here are a couple of thoughts

  • Try running for a period of time after booting into Safe Mode … this will help rule out a 3rd party app interaction
  • Could you identify the actual ‘system update’ you installed? The Republic Announcements & News should list them all

#11

I’ll try safe mode when I can do a controlled experiment, i.e. get some one to text me, verify not working, go to safe mode, and see if anything changed.

Looked it up, the update notice was 11/15/18 for Moto G5plus, build OPSS28.85-17-2. Looked on the phone and that is in fact the installed build number.


#12

The “vibrate” is add-on which you can disable if you just want the notification sound.

Messages -> Settings -> Notifications


#13

Yes, I have had that set off for years. Doesn’t vibrate when using the sound I set, does when using the default.


#14

So basically Safe Mode appears to be no different. However, gathered more data, all of this is in safe mode, but I expect the same is true in normal mode

Started texting with two people, A and B, using 2 different threads. Using a thread with just A and myself, I get my custom sound like it should be. When A texted using a thread with both A and B and myself on it, default sound. Same with B when using the common thread. When B texted using a thread with just B and myself, default sound. Was thinking it might be an SMS vs. MMS thing, but the last data point seems to disprove that theory. Further more, at least 2 of the texts out of 10 or 15 came thru with NO sound, just vibrate, even though it is off. All default sound notifications also had vibrate.

Note that A and myself are on the same Republic account, B is not. Can’t think of any other differences


#15

Sorry, but at this point I am afraid I have nothing else to add … hopefully someone else can chime in with additional thoughts :frowning:


#16

Can you try this and let us know if that helps disable Vibrate for the default notification?
Settings -> App & Notifications -> Messages -> App notifications -> Vibrate (disable)


#17

Well, there is no switch for vibrate in ->App notifications. The top one is “On”, next one down is “Allow notification dot” which is on. (This dot thing is new with this update … ?)
Then there is a list of conversations that matches those I have going in the app. I just accidentally tapped one of the conversations, and there are a bunch settings there including sound (set to default) and vibrate (set to on) ! So I went looking for the single conversation with A that I talked about above, and it is NOT in this list. That’s the one that the sound is not the default. I don’t have time to experiment right now, but i’m betting these settings are overriding the in-app setting and if I were to change them one by one it would work. I don’t understand why one of the conversations isn’t in the list, but that is the one that works. It would be annoying to have to change each one, especially every time I start a new one. Don’t have time now, but will experiment with this more later today.


#18

I didn’t have any custom notifications.

When I changed the notification for one my conversations to a custom setting, the “vibrate” on/off option went away at the location that I outlined earlier.

If you have several conversations with custom notifications then scroll down that list…and at the end you will have a category “Other”…tapping on that will get to the options where you set your default notifications for messages that don’t have a custom notification.

Once you have a conversation with custom notifications…there doesn’t seem to be a way to get rid of it from the list of custom notifications…even if you change it back to default notifications.


#19

So it looks like I will have to change every conversation that is in the list. I don’t know how I got almost all of them to be in the list, which really isn’t custom, every one in the list is set to the default sound and vibrate. And the “other” at the bottom is set to the custom way I want it, but it doesn’t change any of the existing ones in the list. This is a screen shot of location you sent, -> app notifications. I blanked out the names, but the list is much longer than shown, basically every active conversation I have. Tapping each one give the option to change it.


#20

I agree that this is poor UI transition. Only thing I can think of is to “Clear Data” of the Messages app but before you do that…you should probably archive your SMS messages using SMS backup and Restore or similar app…make sure the restore works as intended and then try clearing the data.