Messages issue on Moto G Power (2020)

What phone do you have? Moto g Power (2020)

What plan are you on?
3.0 plan
Does your plan include data, or just talk & text? Talk and Text only


Issue Description

Can only use text messages while connected to wi-fi. Have had this phone since Nov. Worked ok originally. Started to see issue when we were on home wi-fi, tried to text while leaving in car lost wi-fi and could not complete text. Now anytime we are not connected to wi-fi and if we get close to any wi-fi in a store it will then send and receive texts. Checked build # is 30.80-63-6-8-5 have the chat off. I thought that I saw an article that temp fix was to turn off wi-fi and just us cell, but can not find it now. Up to date on Moto, last patch Jan of 2021

Try disabling the RCS chat features in Messages by Google. RCS chat features would require having a data plan, when on cellular, for sending/receiving RCS messages:

Already checked that and it is off. We were able to text and call between our moto G 1 and the newer moto G power 2020 when we went outside away from out home wi-fi. We then sent text to two different family and the text did not send. We believe when a car went past us and then one of the text sent, it might be that they were using their phone and we connected to their wi-fi. Back home, the one that hasn’t sent shows 47min SMS. The people that we are texting all have iPhones. Do we need a different message app instead of the google app? Do we need data plan for this to work?

The answer should be no to both. While you don’t need a data plan, you do need cellular data enabled. You haven’t shut it off by chance, have you? Also, are you seeing an LTE indicator by the cellular signal indicator in the upper right of the phone screen?

If I see the right triangle image with most of it filled in, that should mean cell is connected?? No LTE next to it.

Is there a place to check cell strength? Watching it now, it seems to show little amount, then a larger amount.

Hi @russellk.nscsba , :slight_smile:

If you open the Republic app and tap on the gear ⛮ , then “Advanced Settings”, scroll to the bottom and you can run a diagnostics test. Please run that and let us know what you find.

Just opened the Republic app and did the diagnostic test and it has cell network is not one of Republics partners, Check if i have R SIM

I have a Republic SIM, do you think it is bad??

I hope not… let’s try this next:

Did the reset. If I turn off wi-fi, I see the LTE, with wi-fi on it is gone. Ran diagnostics again with wi-fi off and with it on. Same cell network operator fail. We will go outside away for our wi-fi and try to see if we still have the issue now. May be awhile before I get back to this message board.

Ok, if the issue is still there when you get back, when back on your WiFi connection please try an activation refresh (it’s my last guess before I suggest opening a ticket).

I went ahead and refreshed the activation. Still get the Cell Network Operator fail when rerunning the diagnostic. Will test texting tomorrow and report back. Thanks for all the suggestions, now we do see the LTE when not connected to wi-fi.

After doing all of the above, I think we are good now. Thanks for all the help.

Message an
Expert customer