Messaging app loses my phone number

What phone do you have?
Moto X4

What plan are you on?
my choice talk and text
Does your plan include data, or just talk & text?
no data


Issue Description

When using the messaging app and sending group texts, periodically I start getting copies of my own messages from a “new” participant in the chat with my phone number. When this happens, I can go to settings and then advanced and can see that the phone number listed is not my phone #. If I change the phone number back to my actual number, the problem goes away for a while but will return after a period of time, sometimes days, sometimes a few weeks. Why is this happening? This doesn’t happen to other family members with the same plan using a moto g7 but it does happen to my mom who also has a moto x4.

I am tired of this problem, can you help me to fix it permanently?

  • Which messaging app are you using?

Hi @jlederma and welcome to the Community!

Based on your description, you’ve tried step 2. Have you tried step 1, first?

I am using the default google messages app.

1 Like

Yes, we recently refreshed the activation on all of our phones b/c we had connection issues and Republic sent us new Sim cards to get better reception. We had the issue with the old sims and it has continued with the new ones.

@jlederma Did you follow the directions in the article above and Refresh your Republic activation?

1 Like

Yes, we have tried everything except factory resetting the phones. Sadly nothing works. It would be nice if Republic would actually fix the issue, but that doesn’t seem likely.

I’ve helped quite literally tens of thousands of Republic customers over several years and there isn’t an outstanding issue that needs fixing because the reset of Republic credentials generally resolves this in every case because it isn’t a bug or a software error but a temporary loss of synchronization which is fixed by reestablishing that link.

Let’s approach this from another direction. First, let’s double check your messaging settings. Please check the following:

  1. Open the Messages App
  2. Touch the three dots on the top right
  3. Touch Settings
  4. Touch Chat Features
  5. Turn OFF “Enable Chat Features”

Was this already off, or was it on?

1 Like

have you read the history on this ticket? Not only have we checked, double checked and triple checked that that setting is off, but we have switched to republic anywhere for messaging and are still having the problem!

This isn’t a ticket, it is a community post. I’m a fellow Republic user just like you are an have no access to your history or anything else. The first thing I would do is stop using Anywhere. Anywhere is no longer developed, and I don’t recommend its use.

Messages on the other hand is in very active development and used by most customers at Republic. There are solid troubleshooting steps we can work through.

The first thing I would do is make Google Messages your default and then to the credential refresh (dialing *#*#8647#*#* in the dialer, which should immediately clear the screen, waiting 30 seconds and restarting the phone). Then start testing an troubleshooting from there.

Happy to help do that if you’d like. If not, I understand.

I’ve tried that, several times on both problematic phones. I’m done. switching to republic anywhere was the last ditch effort to fix things and it failed.

OK, best of luck to you.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer