Minimize Disconnect Time When Moving between WiFi Access Points

TLDR: Any tips for making RW reconnect with the servers faster when moving between WiFi access points with the same credentials?

I work in a semi-rural area with mediocre cell coverage. Unfortunately, most of my time is spent inside cement or metal-lined rooms, so cell service is basically out of the question unless I step outside. But since RW can use WiFi and we have cable internet, I usually have no problem with calls.

The issue arises when I have to frequently move between buildings and, subsequently, between access points. My phone’s operating system gracefully and quickly switches between them (since they all have the same login credentials), but the RW app often doesn’t and takes a few seconds or several minutes to reconnect (sometimes longer if I don’t wake the phone up). During this disconnected time, I have missed calls or have been unable to make outgoing calls. I can manually resolve the issue by resetting the RW connections in the app. That is, however, a little tedious. I’m aware this may be a technical limitation of the implementation, but I’m still curious: does anyone have any advice on how to reduce RW’s non-WiFi time when moving between access points by modifying the phone or network?

Phone: Google Pixel
OS: Android 10
RW App: Not Battery Optimized

1 Like
  • You may want to check out either of these apps. I have used these in the past where I was using multiple AP in a large 1 story house and have not tested with 9.0 code that I am now on
  • Each has limitation, but the app and host links provide good guidance.
  • The problem is the WiFi adapters tend to ‘hang on’ to a signal much after it has become usable, and this will allow you to set the disconnect levels with a bit of experimentation.
2 Likes

Thanks for the suggestions. That’s not quite my problem, though.

My phone does a pretty good job of switching between access points. Whenever it does, however, RW goes into cell-only mode for a while, which is rather inconvenient when you don’t have any cell service.

So, if I understand the environment, it is a multi building complex, however the outdoor WiFi allows the RW App to handover to the poor/non existing Cell when the signal degrades?

  • Something to consider
  • Change the RW App/ Settings / Advanced Settings / Enable handover on networks
    • All networks that you sign into will turn this on (by default) however you can ‘Deselect’ yorr Work SSID/Network Name which will prevent its attempt to handover to cell
  • Use this by itself to see if it helps, and then consider adding the app in my first suggestion to help pick up the stronger signal as you travel between locations
1 Like

Correct, there are multiple buildings with an access point in each one. When I hop from one building to another, the RW notification shows cell-only for a while before reconnecting to WiFi (despite the operating system doing it almost seamlessly). During this hesitation is when I cannot make or receive calls. I usually try to stay in one place when on a call for fear of dropping it, so I haven’t tested moving between access points on an active call.

It appears “Enable handover on networks” is not available on Android 10; however, active calls aren’t the difficulty.

The situation isn’t a deal-breaking, just an inconvenience.

This is not a function of the Android OS, it is part of Republics code and changing it is from within the app as noted above

1 Like

Ha, yep. It’s grayed out for Android 10 users. Thanks though.

Hi @larsh,

It might be annoying for those times you are around adequate cellular coverage but have you considered using Airplane mode with WiFi manually reenabled? Doing so would disable the cellular radio making it impossible for the phone to try to connect to the cellular network.

1 Like

Thanks, I have always said a good day is when I am still able to learn something new !!
I guess this would leave us only going into Airplane Mode and turning the WiFi back on.
Once armed with this new found knowledge, it was easy to find this Option to Enable Handover Greyed Out – Republic Help by doing a search of the Help Center … using the Tab that @southpaw recently added image

I did a quick check, hoping this could be done with MacroDroid, but it requires the phone to be rooted (a place I have never ventured)

Just did some quick tests with my phone. Turning airplane mode on and enabling WiFi doesn’t help. I was unable to make a call until I reset the RW connections in the app (if left alone, it would eventually sort itself out).

Interestingly, I think the RW app establishes a connection with the servers faster when using the main router’s WiFi as opposed to the access points’. I’ll have to keep an eye on that.

Hi @larsh,

I don’t think the handover setting would change the issue you’ve described, since you didn’t mention calls dropping. However, if you’d like to see it enabled for Android Q phones, please open a Help Ticket, explain that you’d like the function enabled, and ask that your request be attached to master ticket 1830710
(I’ll update that help article with the same information.)

I can’t think of any way you could speed up the reconnection to our servers.

Among the networks available, do you have choices of 5 GHz or 2.4 GHz networks? If so, try selecting the latter.

1 Like

I agree that changing handover setting probably won’t make it better. And I doubt 5GHz channels would improve anything (it’s not that much data to ping a server - well, for a single phone).

Upon further experimentation, it almost seems like a lottery on how fast the RW app reconnects to WiFi. Sometimes it’s near instantaneous. Other times it takes several minutes. Access point vs main router and airplane mode don’t appear to consistently shift the odds in any direction. It’s fun trying to unravel the mystery, though.

1 Like

Hi @larsh,

I wasn’t suggesting 5 GHz would improve the situation. I asked if both frequencies were available and suggested you try the 2.4 GHz frequency. It has a greater range and my thinking was that you might experience a more seamless transition between APs if there was more overlap between them.

2 Likes

Oh, misread you comment. That makes sense.

However, I’m already on 2.4 GHz for that reason (even though 5 GHz is partially available). :grinning:

1 Like

The reason I suggest an app to aid in dropping the weak signal is to maximize the effect of the distance that the 2.4 Ghz will carry. I am assuming that this is an Enterprise installation and that the AP’s are on different channels? Reference link

No, this is not an enterprise setup at all. Just several home-grade WiFi routers/access points that we’ve setup across the area, all connected via Ethernet cables to the main router.

I don’t think a WiFi-switching app will help. The phone switches across AP’s just fine. I can keep on browsing websites with my phone as I move between buildings. The RW app simply isn’t as eager as the OS to switch between AP’s with the same login credentials (acronyms are awesome).

ok, my foggy and very old brain seems to remember something that was written early in RW’s life. It was something along the line of this:

  • To prevent users from locking in on every storefront they pass while driving (and on cell), there is some delay in the RW App shifting to WiFi from Cellular.
    • I am not sure if that was ever a fact or not, and this could only be verified by Republic’s Engineers.
  • On your channel layout … I haven’t had the need to run multiple AP’s since moving out of a sprawling ranch in Texas 4 years ago, but I relearned a couple of things
    • Devices will not attempt to connect or re-associate to a new AP/Channel until it has dropped the current channel (This will prolong the time that Republic will delay (assuming they still do) and the signal quality is good enough for the solid RW Arc, allowing calling etc) … this is why I will stand by my previous suggestion of trying the previous app for controlling the switching to the strongest signal.
    • A brief writeup on how to: Assign Access Point (AP) Channels
1 Like

I believe all of our access points select the best channel themselves (seems a standard feature these days), and there’s not many other WiFi networks nearby.

Your first point, though, sounds rather probable. I know some people have gotten annoyed when their phones tried connecting to every xFinity WiFi network whenever they were driving through a city. Adding a delay to ensure the connection is stable is certainly logical. I, however, don’t have xFinity WiFi access and rarely travel through towns, so more aggressive switching settings, at least for certain networks, would be quite appealing (if there’s a suggestions box :smiley:).

On your 1st point ‘best channel’ … AFIK , Many vendors set them to Channel 6 by default and the majority of AP’s/Routers set to Auto, channel selection is only done at Power On Time, neither of these practices take into the consideration the needs to ensure good roaming handover.

  • You could consider installing an app like WiFi Overview 360 and take a walk around your complex
    • This should allow you to see each of your AP’s, the channel their on, MAC address, etc. As you use a single Network Name/SSID, you will see multiple entries, something like I show for my single AP as my SSID is Ubiquiti and it shows me Connected on the 5 Ghz channel

    • I would make note the Connected AP, its power level and channel … then again after it changes to the next AP … if they are all on the same channel, then use the MAC address to differentiate

      • This will be helpful in determining if changes could be recommended
Message an
Expert customer