MMS sent aren't reaching third party phones all the time

My texts are not being received by third party phones. This just started during this past week.

which app are you using?

which carriers are you routing to ?


I have not been having any issues sending MMS to a Cricket user on my Moto X 2nd using Google Messenger


Since the phone is a X2 are you using the native messaging app or Google messenger or even a 3rd party app? I suggest whatever app you are using delete it and reboot the phone, reinstall the app again and see if that fixes it. Be sure to backup the texts if you need to keep them.

SMS Backup & Restore - Android Apps on Google Play

*** ~~ßocephous™ ***

Using the original app that came with my phone. I’ve been with Republic two years and this is the first time I’ve had this problem. Verizon is the carrier of 95% of my friends I send texts to.

I’ll give that a try. Need to read the instructions.

And I’m using the native text app.


Is the phone freezing up or are you getting any code messages?

*** ~~ßocephous™***

Republic had some MMS issues last week. However, MMS should be working now. I would open a support ticket if the troubleshooting section listed above doesn’t help.

Republic Help

Republic Wireless Status

Yeah, saw the conversation about the general problems Republic’s system had. I cleared the data and cache of the message app.Forced stopped the app. Shut down the phone and restarted. Enabled roaming data. See if any of these help. Thank you ALL for the suggestions. Going to sleep soon, see what the morning brings. Thanks again! Doug

No freezing or coded messages. Just no responses from the recipients. Call them later to find they didn’t receive my texts until I call and they show up as we speak, strange. Maybe that means something to some one who truly understands how code/systems work. Thanks for the inquiry. Doug


I had a couple delayed texts to my wife early in the week and just thought it was system status issues.

*** ~~ßocephous™***

It’s Monday morning and my phone has seemed to snap back to its old self. I did uncheck the allow roaming for cell data that I’d checked because of a suggestion, or did I read it somewhere? But, Thank you all, for your suggestions and just plain hand holding as I navigated thru this.


Message an
Expert customer