MMS Text Issues (Again)

I won’t go into the whole long drawn out story, but I seem to have found myself right back in the same place as I was a couple months ago with my old Moto X (2nd Gen) where MMS wouldn’t work. After a very lengthy process with support going through all the steps to try and fix it, and wiping the phone and reseting back to stock and testing in safe mode and a host of other things, it was most likely determined to be a fault of the hardware. I didn’t completely understand but after putting so much time into trying to make it work I was at my wits end and gave up and bought a new phone. The new phone (Nexus 5X) I haven’t had a chance to use a lot in terms of MMS but have recently started to use it more and am back in the same boat all over again, MMS that never show up on the other side.

I’ve gone through the same steps again, clear app cache, clear messages, wipe system cache and finally reset the phone. No dice though, same issue, on my side texts say sent, but on the other side they never show up. This is trying to send to someone on AT&T. I’ve researched this out and am fairly sure AT&T doesn’t accept MMS larger than 600Kb, could be a little larger now, but 600Kb seems to be a safe number. So I’ve only sent MMS smaller than that, 300, 400, 500Kb. But nothing, they never show up on the other side.

Is there something I’m missing here that is really obvious? Or is this a Republic specific issue since I don’t seem to be having much luck and am now on my second phone that doesn’t seem capable of sending MMS

Thanks

@mikes.2a6lg4

The stock Messenger is the problem if you haven’t changed it. the Google messenger is recommended! Set this as default when you install it and try using it. Messenger - Android Apps on Google Play

*** ~~ßocephous™***

The stock and default messenger for the Nexus line is Google messenger

As drm186 mentioned the stock messenger app on my Nexus phone is Google Messenger already. So I don’t think that’s the problem, but I’m totally open to any and all suggestions as at this point nothing has worked.

Thanks

@mikes.2a6lg4

Thanks again @drm186 on my oversight again. Another suggestion is to uninstall all updates reboot the phone and reinstall the messenger updates. I have found this to work on some stubborn apps.

*** ~~ßocephous™***

Here is an official doc on sorting out issues like this.

Troubleshooting Texting Issues

However the way I am interpreting your description it sounds like MMS worked for a while and then stopped, on both phones. If that is the case try running the phone in Safe Mode for a day or two to see if that eliminates the issue. If it does then you likely have an app conflict and will need to remove the app that is causing this. To get to Safe Mode push the Power button like you would to power down the phone but when the ‘Power off’ dialog box pops up press and hold it until it offers the option to reboot in Safe Mode. To leave Safe Mode just reboot.

Also not all carriers are up to speed on the new texting over Wi-Fi protocols. (But AT+T is not one of them.)

Unsupported MMS Providers

Condition’s Chart Information
working-on-the-solution.png
Condition Number:

N/A

Impact:

**medium impact.png
**

Latest Update:

03/22/16

Last Reviewed:

06/09/16

Date Opened:

01/17/14

**symptoms_title.png
**

  • You’ll be unable to send or receive MMS messages (this includes group SMS) with Cellcom, Ting, Net10, SafeLink, MetroPCS, and Simple Mobile.
  • Only MMS is affected, regular text messages (SMS) work fine.

**diagnosis_title.png
**

As providers continue to update their networks, there are some providers that don’t support MMS messaging with Republic yet.

**treatment_title.png
**

We’ll continue to work with and reach out to other providers to properly set up testing on both sides to get MMS working.

Thank you for the suggestion. I looked to try and uninstall updates and it seems the interface is different on Android 7.0 and don’t see the option in the app settings to uninstall updates. Is there somewhere else this is handled now? Thanks

it’s done though the google play store

Thank you for the suggestions and info. Yes, basically both phones have developed this issue, and both in completely stock form without me adding any apps. I factory reset both phones to stock and they both continued having issues being unable to send MMS. I also spent some time in safe mode with both phones with the same results, still no MMS received.

I went through that official doc with both phones and did every single item and unfortunately still had/have the issue with MMS not working.

I’m kind of baffled at this point how I can’t seem to get around this issue and that MMS basically just does not work.

Hi @mikes.2a6lg4,

Messaging issues are not my forte, however, I’ll throw my two cents in, which may be what it’s worth.

You reference an issue sending MMS to a recipient on AT&T. Have you tried sending MMS to a recipient on another service provider. I’m not throwing AT&T under the bus on this but it would be worthwhile to know if the experience is the same sending to other service providers. Likewise, do you know more than one recipient on AT&T? If so, could you try sending MMS to them to see if the experience is the same.

Google Messenger certainly should work on your Nexus 5X but you could try a different texting app. I’m using Textra. If you decide to give Textra a try, you’ll need to tweak its default settings as follows:

  1. Open Textra.
  2. Tap three stacked dots upper right.
  3. Tap Settings.
  4. Scroll to then tap MMS.
  5. Tap MMS Behavior.
  6. Select System.

If there are no added apps it can’t be a conflict. And if a factory reset didn’t fix it then it’s not a software issue.

This leads to the notion that both phones somehow developed a hardware defect that prevents MMS messages from being sent. And I can’t even imagine how, or what, that could be.

There are other possibilities such as a problem with a tower losing your message instead of forwarding it. Not likely but not impossible. And it could be periodic too; works fine for a while, tower goes haywire, gets fixed, goes out again. But the time frame for the ups and downs would need to be a major factor too.

The only issues I know of that can survive an FDR are hardware failures and corrupted Android OS cache files.

Clearing the Cache

Does it happen with other carriers as well?

Well as of right now that is working! I tried Messenger a bunch of times trying to send the person on AT&T MMS messages and none of them went through. So I downloaded Textra and adjusted the settings as listed and all of my MMS messages I’ve sent using have gone through and been received.

I have no idea why Google Messenger won’t work, but it does not and Textra does. I never thought to try another app because the official Republic doc is fairly adamant about using only Google Messenger with 3.0 phones.

Hopefully Textra keeps working! Thank you!

Just changed from Google Messenger to Textra based on the recommendation below and somehow Textra works for MMS and Google Messenger does not. I’m confused how that is the case, but I’m not gonna argue it and just hope it keeps working.

I’m glad that Textra seems to have solved your problem. Textra, in my opinion, is far better than the standard messaging app anyway. I have been using it ever since I got my Nexus 6P on the RW 3.0 plans. Be sure to use the “TextraBot” feature to get great hints on the nifty features of Textra. Actually, being able to use the great texting apps like Textra is the single thing that I like best about moving to the 3.0 phones. I have tried Handcent, Evolve, and Textra, and find Textra to be my favorite, mostly due to its smooth, uncluttered, and elegant interface.

Having said that, while texting on my Nexus 6P on RW 3.0 seems to be significantly more reliable than texting on my older Moto-X (2nd gen) on RW 2.0, that isn’t always the case and it’s definitely still not perfect. For example, my daughter (using her Verizon phone) sent a group SMS text to my wife (who is using my old Moto-X on RW 2.0) and me (on my Nexus 6P on RW 3.0) and my wife got the text immediately, while it didn’t show up on my phone until more than an hour later. That was on our home’s WiFi. However, I will admit that that’s not common. Usually in the same scenario we get the texts at the same time. And I think that texting to/from my 3.0 phone is significantly more reliable when on a cell network than the 2.0 phone.

mikes.2a6lg4 wrote:

Hopefully Textra keeps working! Thank you!

I wasn’t having issues with the Google app on my Pure or Ascend but didn’t like the UI as well as the default on the legacy phones. Have Textra now on both and working fine as on yours. Keep my Play auto-update setting on off to prevent surprises with apps such as Textra.

You’re most welcome!

Indeed Republic does nag about using Google Messenger. I’ll concede from a support perspective standardizing on a single app makes sense. On the other hand, one of the things I like best about Community is we can “support” that which Republic might not be able to.

Google Messenger ***should ***work on your Nexus 5X. Candidly, I don’t know why it doesn’t and it does work for me on three household Republic 3.0 phones (Moto X Pure, Samsung Galaxy J3 and Huawei Ascend 5W). That said, I find I prefer Textra. Theoretically, any messaging app that supports the Android System API should work with a Republic 3.0 phone. Getting them to do so would likely take default settings tweaks similar to those I outlined for Textra. Other messaging apps, I’ve seen reported in Community as working on Republic 3.0 phones include Chomp, Evolve and Handcent.

On a similar note: My wife’s Nexus 5X would not send MMS as well. (Meaning it never would leave the phone, period.)

BUT ONLY WHILE ON WIFI. (Turned Wifi off and it would send no problem) I had since brought my Moto X Pure Edition to Republic 3.0 and NEVER HAD AN ISSUE AT ALL. And now I knew this was PHONE SPECIFIC because we were ON THE SAME WIFI.

She was activated within the first week of Republic rolling out 3.0 w/ a BYOP SIM card.

The issue would go away, and come back. And although we tried all the troubleshooting steps provided by Republic’s Support system, nothing worked COMPLETELY.

Finally, after the recent 7.1.1 update to Android and a FACTORY RESET, it would not send MMS AT ALL.

AS A LAST DITCH EFFORT I SWITCHED HER TO MY OLD MOTO X ON 2.0…MMS WORKED PERFECTLY.

However, in trying to SWITCH BACK TO NEXUS 5X ON 3.0, I was informed by Republic that the SIM card is no longer valid and that I would need to order a new one to activate (another dumb MVNO policy, but I digress).

Since I had another Republic 3.0 SIM still unopened (from their kind gesture in rewarding those who signed up early with extra SIM cards) I popped it in the Nexus 5X , activated, sends MMS PERFECTLY.

NOT A SINGLE ISSUE SINCE.

Did not have to switch from using the recommended Google Messenger app. Although if someone prefers Textra and that works, that’s awesome as well. However, that’s simply going around the issue and not actually resolving the core problem, and because I’m a nerd and a detail person, I wasn’t satisfied w/ that :slight_smile:

Great, but baffling to me also, to hear that switching to the Textra setup has worked for you. Hoping it continues to function.

That’s very interesting to hear. I wonder if possibly the same issue exists with my Nexus 5X and it has something to do with the SIM card. I never really thought about that before, but wonder if it’s worth looking further into. I’m afraid to mess with it since Textra somehow seems to work right now even though Google Messenger won’t work. I guess I could buy another $5 SIM card and try again to see if I can get it to work. I’d hate to screw it up though and then be back to not having MMS work at all. But good to know that maybe there is something more happening and it has to do with the SIM card. Thanks

If it ain’t broke …

Message an
Expert customer