Mobile data not working with new Galaxy s8


#1

What phone do you have? Samsung Galaxy s8

What plan are you on? My Choice Plan + 2 GB

Does your plan include data, or just talk & text? Includes data


Issue Description

I recently broke my Nexus 6p and purchased a Galaxy s8. Since moving my plan to Galaxy s8 I can only text and call while not on WiFi. Mobile data has not worked on the Galaxy s8 since start up.

The only thing I have attempted in order to correct the problem is to Update Profile and Reset network settings and Refresh the Republic Wireless Activation.


#2

Hi @whith,

I take it accessing mobile data on the 6P was not an issue? did you move the SIM from your 6P to the S8 or did you use a new SIM? Either way, let’s get some information about that SIM. Is is GSM or CDMA? Republic’s how to on determining that is here: How to Tell If a Phone Is Active on GSM or CDMA – Republic Help.

Additionally, may we know the zip code(s) where you’re having this experience?


#3

Hi @rolandh.ps1bgl

I did not have any issues with accessing mobile data on my 6P. I used a new SIM from Republic. It is CDMA.

I live/work/drive in the Raleigh-Durham area, specific zip code of my home address is 27612. Work zip is 27701.

Thanks for the reply!


#4

They build the map by driving the routes in an auto and gathering data from multiple phones and carriers. This data is then analyzed and you can see what the actual results were (as well as the number of data points available) … I feel this is far superior to the standard carrier provided map
Here is an example of the granularity they provide (as well as carrier select that includes both used by RW

image


Both RW, one has service, another doesn't
#5

You’re most welcome and thank you for the additional information!

CDMA coverage in and around Raleigh should be more than adequate. Do you happen to remember if the 6P’s SIM was GSM or CDMA? If you still have it, take a look at it. Is the lettering for the word Republic a mix of green and black or is it all gray or all black?

Meanwhile, let’s try a few things on the S8:

Please check to see if Data Freeze was inadvertantly enabled in the Republic app. More from Republic on that here: How to Enable Data Freeze in the Republic Wireless Application – Republic Help. If it’s on as Republic describes, please turn it off. Next:

Open Settings.
Tap Connections.
Tap Data usage.
Is Mobile data toggled on?
Tap the back arrow.
Tap mobile networks.
Is Data roaming toggled on?

Please let us know and we’ll go from there if need be.


#6

The Republic pop-up shop can usually help with hand on support in person. Looks like you are in the neighborhood. (What was that show with the guy and the shoes & sweater?
https://help.republicwireless.com/hc/en-us/articles/115016002948-Where-is-the-Pop-Up-Shop-Located-
https://help.republicwireless.com/hc/en-us/articles/115015610347-How-to-Schedule-an-Appointment-at-the-Republic-Wireless-Pop-Up-Shop


#7

Thank you again for all the suggestions!


#8

If you still have the 6P and its SIM, remove the SIM from the phone and look at it. If the lettering for the word Republic is a mix of green and black it’s GSM. If the lettering is all gray or all black it’s CDMA.

Next steps: How to Reset Cellular Settings on Samsung Galaxy Phones with CDMA SIM Card – Republic Help. I understand you’ll be repeating the Data Profile update but do not believe you tried resetting the cellular settings first.


#9

The lettering on the SIM card in the 6P was a mix of green and black, so it was GSM.

I also tried the “Next Steps” from above. Still nothing.


#10

@whith Are you still having this issue?


#11

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.