MOTO E 2020 can't connect to work wifi

I have a Moto E that will not connect to the wifi at work. We have just revamped our entire IT network after our company was acquired by another. I could connect to the old network fine - choose connect, I would then be prompted by my phone to sign into the network; it would open its own little browser so I could give it my name and email, and then it would provide me with login credentials for the day, I hit login, and I was connected.

What is supposed to happen for the new network is: connect by entering password. Then manually open a browser, which will bring me to a site to complete the login process - this never happens; Chrome opens as normal to either the home screen or whatever tab I had open. If I turn off cellular data, the home screen tries to load but just sits and spins - it never loads the login screen; in the network list it says saved, but If I look at it later, it says “disabled”.

I tried connecting via the Netgear Genie app, which looks like it’s connecting and then says connect successful, but I’m not connected, and opening browser does the same thing.

IT has so far not been able to offer any help. No one else’s phone has this problem. Any suggestions? Thanks.

  • Can we assume that you have ‘Forgot’ the old network and actually see the new network?
  • Are any of the other working phones on Republic Wireless?
  • Which Moto E do you have?
  • Old network is gone - physically ripped out of office. I can see the new network, attempt to connect, modify or forget, etc. Clicking on it for initial connection asks me to enter password - I do, say ok, and then it just goes to being “saved” on my wi-fi list. No indication that it was connecting, configuring IP, or anything.
  • As far as I know I’m the only RW user.
    -Moto E 2020.

Thanks.

ok, Could you share the required setup that IT provided?
Things like select 802.1x EAP, EAP method etc

The settings are mostly hidden - it asks for the password, and if you expand the “advanced options”, they are “metered” (set to detect automatically) , “proxy” (set to none), and “IP Settings” (set to DHCP), but IT said I shouldn’t have to do anything with those.

Wifi Analyzer tells me it’s WPA2 security, and operating at 5Mhz and 2.4Mhz.

Hi @mattg.8z0nvd,

Just to be clear, there’s nothing Republic does to any phone that would affect its ability to connect to a WiFi network.

Could you share a screenshot of the screen at Settings > Network & internet > WiFi > the network name, so we can see the options there?

For security reasons I am reluctant to share this. I have outlined the generic settings in the last response to Jben.

So it sounds, your IT folks don’t specify any specific settings other than SSUI (network name) and password?
Is there any written document you could share?

There are no written documents, and nothing I would be able to share, anyway. This wasn’t an issue with the old network, and this should work exactly the same - give a password, accept default settings, and be prompted to sign in. Mine is the only phone in the office having this issue.

I’m wondering if this has to do with the fact that RW is VOIP? Like the Venmo issue? Grasping at straws here.
IT is looking into it but pretty much treating it like it’s RW’s issue. BTW I have a ticket into RW.

Not VoIP issue.

Consider finding a colleague that can connect, and compare network settings.

Again, I assure you, there’s nothing specific to your phone being on Republic’s service that would impact its ability to sign into a network.

Okay. Can you tell me if you see a setting for “CA certificate”? If so, please tap it and try setting it to Do Not Validate.

1 Like

In going back over this, I see a statement you made that may be a clue

  • I would compare your browsers settings to someone who this works for
1 Like

When you open the browser, have you tried going to a website (that you don’t visit often), such as apple.com? Sometimes trying to browse the internet may trigger the page to be loaded.

You can also try this. Find out what system IT is using for WiFI and if there is an associated IP address or name that the authentication page is on. For some Cisco systems, this is 1.1.1.1 or https://1.1.1.1

As you used to access the old network, make sure you Forgot the old network. You can also try clearing your browser cache in case something is still “stuck” in your browser from the old authentication page that’s interfering. Clear cache & cookies - Android - Google Account Help

3 Likes

Have you asked your IT folks to help? Where I work, they solve these kind of issues all day long.

Message an
Expert customer