Moto E (2nd Gen) My cellular data isn't working. How can I get it to work?

What phone do you have?
Moto E

What plan are you on?
Unlimited talk & text

Does your plan include data, or just talk & text?
Talk and text by default, but I purchased data.


Issue Description

This has been going on for a couple of days, but it’s never been super relevant. I can’t access any webpages or apps that need the web on my telephone using only the cellular data. As far as I can tell, wifi works fine.

I tried resetting the phone but that didn’t work. The republic app tells me that I have plenty of data left-- 512 MB and 0MB of cell data used.

Thank you for any help!

You may be running into a memory constraint that others have seen on their older gen phones.
You may want to check out the Tips & Tricks by @carlh

1 Like

I have 490mb available. Is that not enough?

Seems like I still get suggestions for trending searches, etc, but I just can’t do anything else.

Hi @nicholep.sjayg5,

You might try the following:

Restart your phone.

Perform a VoIP Reset:

  1. Tap the Phone icon.
  2. Tap the Dialer icon.
  3. Dial *#*#8647#*#*
  4. The dialer will disappear. If an activation screen appears, wait for the process to finish, then tap GREAT THANKS!.
  5. The Republic Wireless notification icon may disappear briefly then reappear. If the icon does not reappear after one minute, restart your phone.

Update the PRL (Preferred Roaming List):

  1. Tap Apps.
  2. Select Settings.
  3. Under System, select System Update.
  4. Select Update PRL.
  5. After the update is complete, tap OK.

Wipe Sprint Settings:

  1. Open the Phone app.
  2. Dial ##72786#
  3. If prompted, tap Yes to confirm. Please do not be concerned by any warning. No harm will come to personal data stored on your phone. Despite said warning, this step is nothing more than a refresh of your phone’s credentials with Sprint’s servers.

Completing the next steps are crucial or your phone will not work on cellular:

  1. Tap Apps.
  2. Select Settings.
  3. Under System, select System Update.
  4. Select Update Profile.
  5. After the update is complete, tap OK.

Your phone should automatically restart after completing the Profile update. If not, please manually restart your phone.

4 Likes

Thanks for your suggestion. I tried completing the steps but the data still won’t work for me.

I don’t know if it’s not working or if there’s something preventing me from completing all of the steps as expected. I was able to unambiguously complete the PRL update, wipe the sprint settings, and update the profile. However, when I tried resetting the VOIP settings, the ##8647## disappeared, not the dialer.

Data still won’t work. I am going to try the steps again.

Actually, when trying to run through the steps for a second time, I get a socket error when trying to update the PRL.

And I think putting in the number for VOIP reset does do something. A little crossed out phone icon appears.

A data connection is needed for PRL update so best to do this on WiFi

1 Like

Hi @nicholep.sjayg5,

If you’re seeing COMMS_SOCKET_ERROR on the PRL update, the profile update should be failing with the same error and if the profile update fails, cellular data will not work.

This occurs when the WiFi network has trouble establishing or maintaining a reliable connection to Sprint’s servers. This doesn’t necessarily mean there is an issue with the WiFi network but to resolve the error please try each of the 4 troubleshooting steps below:

Power the phone Off then back On 2 or 3 times to see if the cellular configuration/profile update completes.

Restart your home WiFi network. Unplug your home WiFi network for 30 seconds, then plug your home WiFi network back in. Then reboot the phone and try another profile update.

On the phone, go to Settings and turn Off WiFi completely then perform the profile update with Wi-Fi Off. Please note this step will only work if you are within a reliable Sprint coverage area. You can double check the coverage at your address by looking here: http://coverage.sprint.com.

Finally, try connecting to a different WiFi network. Public WiFi hotspots (i.e., McDonalds or Starbucks) will allow you to complete the update after successfully connecting to the public WiFi network. Remember, when connecting to a public network, you may have to open your web browser and accept the network’s Terms of Service before you have complete access to the Internet. Once you have successfully connected, verify that you have a solid Republic arc in the top left corner of your phone, and that your Republic Wireless notification says “Great! WiFi Calls, Messages & Data.” Once you have the solid arc, attempt the profile update.

If after you have attempted all of the troubleshooting steps above, you are still experiencing difficulties please let us know.

2 Likes

I completed the steps rolandh outlined at least once but it did not resolve the with the data not working.

Hi @nicholep.sjayg5,

Both sets of steps? Are you still seeing COMMS_SOCKET_ERROR on the PRL and/or profile updates?

1 Like

It works now. Thanks for your help.

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer