Moto E4 - Data Transfer not available


#1

All the documentation I have seen, tells me to swipe down the status bar and go into the USB Charging icon. When I swipe the status bar down, I don’t have the USB Charging.

How can I access the data in my phone from my computer?

Thanks.


#2

Hi @stephenc.g9roqa

Which type, PC(?) and which operating system would be helpful information.

Are you sure you are using a cable that is capable of transferring data?.


#3

It’s an HP desktop running Windows 10. The cable is good. I use it on other devices without issues (including my last Moto phone).

Best I can tell is that it’s an issue with the phone.


#4

@stephenc.g9roqa

Is there an Auto-play dialog pop-up on the W10 computer that is waiting for a response? If so, select View files

If not, then please try the following:

Leave the cable plugged into the computer.
Unplug the cable from the phone and wait a few seconds
Plug the cable back into the phone and then swipe down from the top of the screen.
Is there a “USB for charging” notification?


#5

There is no pop up dialog when I attached the phone to the computer, there never is.

Unplugging, waiting and re-attaching has no effect. No pop up and no USB Charging icon. There is a battery icon that shows that the phone is charging, but that allow provides details about the status of charging.


#6

Thanks for checking and reporting back.


#7

Please confirm you are using a single finger swipe to view notifications when looking for the USB toggle.


#8

Both single and two finger swipe present the same list of notification icon.


#9

Hi @stephenc.g9roqa,

Pictures as they say can be worth a thousand words.

This is what you should see on your E4 after swiping down from the top of your phone when connected to your computer:

Tapping the notification will allow a change from charging only to file transfer:

If you’re not seeing this on your E4, I would suggest trying another cable known to be a charge and sync cable (some are charge only). I appreciate you reference the cable you are using works with other devices, however, MicroUSB charge and sync cables are cheap and readily available. It would be worth trying a different cable before moving onto other potential troubleshooting steps.

Please note the posted screenshots were taken on an E4+ (it has a bigger screen and battery than your E4 but is otherwise the same phone).


#10

Thanks for your response.

I am now seeing the USB Charging notification. It appeared yesterday while I was pocking at the phone trying to find it.

Is this something that has to been done every time I connect the phone to a computer?


#11

Yes. Glad you found it.


#12

You’re welcome!

Very happy to hear that.

In theory, the default can be set in Developer options but this has never worked for me. I’m on macOS not Windows. I don’t see why that should make a difference but if you’d like to try Developer options for yourself, here’s how:

  1. Open Settings.
  2. Scroll to, then tap About phone.
  3. Scroll to, then tap Build number 7 times.
  4. You’ll be congratulated on becoming a developer.
  5. Exit Settings.
  6. Reopen Settings.
  7. Scroll to then tap Developer options.
  8. Scroll to, then tap Select USB Configuration.
  9. If needed, tap MTP (Media Transfer Protocol.

As I said, in theory, the above sets the phone to default to file transfer rather than charging only but has never worked for me.


#13

There is a good reason for the phone to ask you this every time and that is security. Without it a rogue public charging location, a borrowed charger, etc would have access to your phone and could potentially do malicious things.


#14

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.