Moto E4 - Do I need a new SIM card?!

What phone do you have? Moto E4

What plan are you on? 1GB Talk & Text

Does your plan include data, or just talk & text? Includes data


Issue Description

I live in the Denver area. Got this new Moto E4 from Republic in January. Everything worked perfectly fine until today. I had been in the mountains near Gunnison since Friday so didn't have much coverage. When I went into town in Gunnison, phone, text, data, everything worked fine. I left there today to come home and I couldn't make any outgoing calls, couldn't receive calls (my daughter said my phone goes straight to voice mail). When I try and make an outgoing call, I get a message on my screen that says, "Cellular network not available for voice calls". I'm now home in Castle Rock (south of Denver) and on my home Wi-Fi and still getting the same message. When I try and text someone, I get "Not sent. Tap to try again". I've shut down and restarted my phone several times today. Earlier today, when I tried to go to the Republic app on my phone it said, "we cannot connect to our networks right now". Now that I'm home and go to the Republic app, I get a big green screen that says "Supported Phone" and "great news! your phone is supported. Please insert your RW SIM. If you don't have one, tap the button below to purchase one". Hmmmm. I deleted some apps and a bunch of pictures thinking maybe that was the problem but now I'm thinking it's not. Thank you for any advice and suggestions! I did not see this particular issue mentioned in the forum topics. At this point (at least for today), I'd like to just switch my service back to my "old" phone (RW Moto G4) until I get this resolved but can't figure out how to do that on my settings on the website. Feeling pretty dumb right now!!!

Try updating your E4 by going to settings>about phone>system updates. There may be 4-5 so repeat until it says your system is up to date.

2 Likes

I am having the exact same symptom set. I am trying the phone update steps suggested. I will share my results.

It took two attempts, but it worked! Thanks for the advice!

2 Likes

Hi,
Thanks for trying to help me! I went to the settings and updated. It’s showing I’m now updated to version 7.1.1.

I am still unable to text or make or receive phone calls but can get my Gmail and can get on Facebook and such. Any other suggestions?

Thanks

Suzanne

I’m quite sure it’s still the update issue. When you check for updates, is the phone showing fully updated? If so, the answer is to power down, remove the SIM card, restart the phone and perform all available updates without the SIM card in the phone and then reinsert the SIM card when all updates are complete. That will resolve the issue.

1 Like

I will give that a try. Thank you!

Another question. My old republic phone that I had before this one still works. If I can’t get this resolved this morning I’d like to switch back to the old phone for now. I thought I could do that through my Account but don’t see where to do it now.

That would be done from the Republic App on the older device.

Thanks for your help with this.

I thought I had the republic app on my old phone but I don’t. I can’t download the app in order to switch phones since I have to do that through the play store right?

Thanks again!

Suzanne

What model is the old Republic phone?

On your old Moto G4, you can sign into Google (if you wiped the phone or something when you got your newer one) and then get the app from the Play Store.

When I try and activate old phone (MotoG4 plus?) I’m getting a message that says, “Sorry but this device and sim pair are not eligible for activation”.

DEVICE ID: ■■■■

SIM: ■■■■2149

Suzanne

What SIM card are you trying to use for the activation?

Message an
Expert customer