Moto E4: New SIM card?


#1

I’m a current Republic Customer. Have been for years. I have the Moto E4. I’ve been getting in and out cell service and getting pop up notifications through the Republic App for over a week now telling me to buy a new SIM card, so I did. I put it in and can’t get my phone to register a cell signal. Only WiFi. I tried restarting the phone multiple times. I tried following the instructions the app told me to follow, but they didn’t work and every time I open the app the first screen that pops up is still telling me to buy a new SIM card.
Ideas, anyone?


* Kudo & Win! *
#2

Please go to Settings – About Phone – Software (or System) Update while connected to wifi. You should find an update waiting. Once it has applied and the phone has restarted, please go back and check again for another update. Once all updates are applied you should find that the phone is working properly again.


#3

You were absolutely right.
Thank you.


* Kudo & Win! *
#4

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.