Moto E4 not getting system updates


#1

What phone do you have? Moto E4

What plan are you on? My Choise + 1GB

Does your plan include data, or just talk & text? Includes data


Issue Description

I have two Moto E4 phones purchased from Republic. One in November 2017 and the other March 2018. Both phones receive regular app updates.

The older E4 has gotten periodic system software updates since I received it. It is currently on “Android security patch level” - March 1, 2018. The “Build number” is NPQS26.69-64-2. This phone has received two system software updates since I received the newer E4. The newer E4 has never received a system software update. The new phone is on “Android security patch level” - May 1, 2017. The “Build Number” is NPQ26.69-27.

What needs to be done to allow the newer Moto E4 to receive current system software updates?

Mike

ps I could not file a Help Ticket, that part of the site does not appear to be working.


#2

Have you tried initiating the updates from Settings > About Phone > System Updates?


#3

Hi @boisemike,

Please try the steps listed here:

We’re not experiencing any sort of outage affecting opening tickets. Could you tell me what it looked like when you could not open a ticket? Was there any sort of error?


#4

I’ve tried this multiple time over 2 months. It just says it is up to date, even though it is not.


#5

You’re suggestion worked like a charm. After a number of cycles, the newer E4 is current with all system software updates that the other phone has received.

The Help Ticket screen showed a small green box in the lower left that said “Our servers are having issues right now. This issue should be resolved shortly. Please wait a moment and try again.”

Thanks for you help,
BoiseMike


#6

Thank you for following up, @boisemike!

Our servers were not having issues, but there is a bit of corrupted data on your account triggering that error. I know how to fix it, but our technicians have asked me to let them know the next time I find one like yours, so they can look into the cause. So we’ll get that straightened out for you over the next few days, as well.


#7

Hi @boisemike,

We’ve cleaned up that corrupted data. Whenever it’s convenient, please let me know whether you now have access to open a ticket. I’d like to be sure that option is availble to you before you actually need it again.


#8

All is good now. I logged in and was able to access “Help Tickets” without any issues.

Thanks for your attention to my issues. This is one of the reasons I like and recommend Republic!

Mike


#9

A post was merged into an existing topic: Cannot log in to open a ticket, new phone issues


#10