Moto E5 Play: Unstable Wifi Connection

wifi

#1

Hello everyone, thank you for your time!

A bit of background information, before all else. I just upgraded (finally) from my old Moto E to a Moto E5 Play. I’ve chosen the +2 GB ‘Choose your Own Plan’, and it includes data due to this.

Once I got my new phone, I ran into a bit of a nuisance that rapidly has become quite a problem. The Moto E5 Play will connect to my WiFi network, and go through all the normal messages from ‘Connecting’ to ‘Connected’, however it will only stay connected for two to five seconds before suddenly disconnecting, and re-connecting once more.

During the short periods of time that it is connected, everything functions just fine. It downloads app updates through it, and after about an hour of timing my screens, I was able to even activate the phone. However, I don’t exactly want to constantly deal with WiFi connection problems–especially since it would slowly eat away at my Data, as small an amount as it may be.

I know for a fact my WiFi is fine, all my other devices are functioning just fine off of it. I tested a few online possibilities, such as turning off WiFi Scanning, but it’s had no change. I’ve also attempted to reset the router, and reset the phone. Unfortunately, my knowledge when it comes to phones is a bit lacking, I’m more of a PC kind of guy, so any information on how to fix this would be greatly appreciated!


#2

Hi @EMBlevins,

Can you tell us when this behavior began? I was actually seeing the same behavior on my phone for the last day or two and I suspect it may have been a precursor to the outage we experienced this evening. I’d be curious to see if the issue clears up over the next 24-hours as all the lingering effects of the outage are taken care of.


#3

Thanks @southpaw!

I got the phone on November 29’th around 5pm est. So it’s possible, though I wasn’t aware that the systems being down could effect an individual phones ability to connect to the WiFi for extended periods of time. I’ll take your advice and see how it works after the problems have been settled and reset the phone afterward.

I’ll be certain to post an update depending on how things go in the next twenty-four hours or so!


#4

Alright, so with the outage finished and fixed, the problem has remained, though I’ve gotten a bit more information that could perhaps narrow down the issue.

I took the new Phone to work and it connected to the WiFi there with absolutely no problems, held the connection instantly and worked for the entire day. However, as soon as I got back home the problem reared its head once more.

This makes me think that perhaps, somehow, my router itself is refusing the phones connection–but I’m not quite certain how it would be doing so. Does anyone have any pointers on what it may be? I’ve had plenty of new devices connect instantly to the WiFi as soon as I gave the password, so this is a new problem for me (laptops, tablets, etc).

Would greatly appreciate any thoughts or possible solutions!


#5

The extra bit helps, at least we now know the phone works with WiFi. To help cleanup any residuals from before you may want to do the following

I realize that other things work fine on you home router, but there are tables that get stored per device, and this will get you off to a clean start


#6

Power cycling didn’t work, unfortunately. I even let it sit for about thirty minutes, all things off, just to be certain. The phone runs on 8.0 which has no direct clear cache feature, as it apparently does it automatically on reset–so I assume the power cycling did it, but just in case I reset it afterward as well to no effect.

I decided to attempt a last resort and factory reset the phone as well, and there was no change. At this point, I’m almost positive that the modem/router itself not accepting the phone completely for some reason.

There’s a second version of my WiFi somehow as well, named the exact thing but with _5G at its end. I was curious if that helped any, as only my phone seems to see it. Similarly, when I looked into the details under the WiFi settings, the IP address is constantly shifting from the correct IP to a long list of numbers until it resets it’s connection once more.


#7

most dual band wifi router (or router/modem combo) have 2.4Ghz and 5.0 Ghz signals.
the _5G is the 5.0 GHZ band, and yes it has helped some by using the 5.0 band over the 2.4 band.
the 2.4 band is older and a lot of older and cheaper EQ that will do wifi still are 2.4 band only…

so if you can hook to the _5G do so and see if it helps…

the IP address that keeps shifting between to what your use to, is the shift from IPV4 and IPV6 IP address. the IPV4 you would see something like 192.168.0.5
whereas the IPV6 you would see something like 2001:0db8:85a3:0000:0000:8a2e:0370:7334

https://www.webopedia.com/DidYouKnow/Internet/ipv6_ipv4_difference.html

my 2¢


#8

Unfortunetly switching to the other WiFi did nothing, although that is useful knowledge to have. Anyone have any ideas on what could be causing my router to block the connection consistently?

Not quite certain what could be wrong here, honestly. I tried a factory reset, and pulled the power for the router for thirty minutes before resetting it again (with the phone off as well until it was finalized in it’s re-boot). Would like to be able to use my new phone though.

If not, anyone have any ideas where I should go to get possible solutions instead? A help ticket maybe–but I’m not certain if that needs to be done on the phone that isn’t connecting properly or not. Since I de-activated it and re-activated my old phone so I don’t run up my data usage.


#9

disable both BT and WIFI


#10

Attempted that as well, no change still. Did it again, just to be certain–also changed my WiFi password to remove all devices and just log in with the new phone–still no change unfortunately.


#11

I would contact Motorola:
https://support.motorola.com/us/en/contactus


#12
  • What is your router (Type/Model/Ver) if possible from label that’s usually on the back or bottom of the router? (one of us can check to see if there are any ‘concerns’ to deal with
  • If you would access the Republic Wireless App/:settingsicon: Settings/Advanced Settings/Run diagnostics test and run this test.
    • It will show the number of Diagnostics that Succeeded/# with Warnings/# of Failures … post back what you see, and we may then want to look at something in the log (hold off on that for now)

Note to all: These Diagnostics are new and not yet fully documented (however the log includes your phone number, so always consider that if forwarding to anyone


#13

Hi @EMBlevins,

It has been about a week since we last heard from you. Have you made any progress with getting your phone to stay connected to your Wi-Fi network?

I was wondering if you have your router set to a specific channel, or if you have it set to “auto.” Sometimes we’ve seen cases in the past where the router selects a channel that is out of the phone’s range, causing the connection to drop.