Moto g 3rd gen won't connect to internet

problem connecting to internet, moto g 3rd generation, when no wifi available. I purchased data, but google maps failed to work, and I could not connect to internet when no wifi was/is available. There were at least “3 bars” on the cell data too. My wife’s I-phone worked like a charm. Any suggestions/solutions??

Hi @chadm.48kca0,

Here are a few things to check on:

  • In addition to the “cell bars” do you also see a 3G, 4G, or LTE indicator?
  • In the Android Settings menu on the Data Usage screen, is cellular data enabled with no limit set?
  • In the RW app on the cellular bars tab, is cell data enabled, and is it enabled for the specific apps you were trying to use?
1 Like

The LTE indicator was on, cellular data was enabled with no limit set, cell dats in RW app is enabled and no installed apps are disabled for cell data usage. Any other suggestions?

If there wasn’t a triangle present on the cellular bar indicator, then our support team would probably need to investigate further. Are you still experiencing the issue?

Here’s a screenshot of what I get when I turn off the WiFi and try to connect to internet.

what does the notification of that !triangle say? (one finger pull down from top of phone)

WiFi is turned off, without your help, I can’t see any WiFi networks! Turn On WiFi. Cell calls & messages, No data.

a followup question what cell provider is your wife’s iPhone on
(I wondering if this is a Sprint tower issue)

Thanks for the screenshot, @chadm.48kca0,

You mentioned that you purchased data. I’m wondering if the phone didn’t get the message that your plan now includes data.

With the phone on Wi-Fi, could you please refresh the Republic activation and see if that makes a difference?

1 Like

You also have 16 tabs open on Chrome. (the Square box with 16 in it)
May be prudent to close them out as that many can often slow down or crash a mobile web browser.

My wife’s i phone uses Sprint network. I did close all of the tabs that were open…just not before taking that screenshot. Just did the refresh of the Republic activation, still does not connect. Any other ideas???

Have you tried resetting the Cellular settings

Hi @chadm.48kca0,

If you haven’t already, please open a support ticket. This is starting to look like it may require technical assistance.

Message an
Expert customer