Moto G Power microphone sharing problem

I saw the request come through and I allowed access to my logs. Then it brought me to a “republic help” screen. Please let me know if you received the logs. Thank you. Also, please let me know where to look for the direct message to provide the diagnostic.

I have the logs, and I’ve sent you a personal message about the diagnostic results. Thank you!

Hello. Any idea what the CQATest app is for? It appears to be an Android app that was either preinstalled or somehow got installed when I activated my phone. Doing some searching, it seems to be an app used for diagnostics, but some people appear to have major problems with this app disrupting their phone. Could this app be the culprit? Can I try to disable it or at least deny it permission to use the microphone? Also, I didn’t receive a message about where to send that diagnostic log. Please let me know where to look for it. Thank you!

Hi @brandong.i1aaku,
My private message to you is here:

CQATest is a quality monitoring app found on many Motorola phones. It is also on my Moto G Power and I’m not experiencing this issue. You can deny it permission to use the microphone to see if that helps.

Thank you. I have denied permission to the CQATest app and my camera. So now there are only 3 left with microphone permissions: Republic Wireless, Phone, and Messages. If/when it happens again, is it safe to assume that it’s not related to an app, or there is a problem with Republic, Phone, or Messages? Do the engineers have any leads as to likely causes? I’m very anxious to get this resolved as it’s a new phone and impacting my ability to perform my job. Thank you for your help!

2 posts were split to a new topic: Frequent handovers on Moto G Power

Hi @brandong.i1aaku,

I replied to your question on timing in your DM to me, but I’ll also address it here so no one thinks I’m ignoring the question.

When we have an issue that we cannot replicate, it is very, very difficult to resolve that issue, and there is no way to make an estimate on the timing of the resolution.

When we have someone like you who is willing to testing things and work with us, providing logs, listing apps, and trying different configurations, that is a great help, and can speed up the process, so thank you.

1 Like

Hi @brandong.i1aaku, and others experiencing this issue.

Our engineering team is asking if anyone can provide a recent call example where this failed, and let me pull diagnostic logs after that example. That allows them to focus on the time period in the diagnostic logs around the failed call to identify potential issues.

If anyone has recently experienced this issue (today?) and can privately message me the phone number of the other call participant and the date and time of the call, then allow me to pull the device logs, it would be a tremendous help.

Hello @southpaw. As soon as I experience the issue again, do you want me to run the diagnostic in the Republic app, or just email you the date/time of the call and let you pull the logs yourself, or both?

Also, @jenniferh.npv2yf @checketts @davidh.1ioxdq @kirkb.ljdm1u @louisdi @garyh.xri4eb @jben Does anyone have the CQATest app installed? It came pre-installed on my Moto G Power and it had permission to my microphone. @jenniferh.npv2yf you didn’t mention that app as being on your phone, but it came pre-installed on mine. On Wednesday night, I disallowed the microphone permission to that app (and the camera) and since that time, I have NOT experienced the microphone sharing issue OR the other issue I was experiencing: frequent handover from wifi to cellular. This could totally be coincidental, as I did not make a ton of calls over the past few days and the calls I did make were not very long, but it is interesting and I will continue to monitor it this week. If I continue to see no problems this week, I could then re-allow microphone permission to the CQATest app and the camera, one at a time, to see if the problem comes back and isolate the issue. Also, do any of you, in addition to this microphone sharing issue, also have an the issue of frequent handover from wifi to cellular? I’m wondering if these two issues I am having are related since they both stopped at the exact same time once I disabled microphone permissions to CQATest app and camera. Still way to early to make any determination, but I wanted to keep the group updated on my status see if anyone has the CQATest app and / or the frequent handover issue.

Hi @southpaw and @jben This morning at 10:14 a.m. when I was trying to dial into a conference call line for work, I entered the numbers and hit the dial button, and immediately received the microphone sharing issue error, saying call could not be completed due to microphone sharing error…Then I dialed again and the call went through. At approximately 10:59 a.m., 45 minutes into the call it handed over to cellular. At about 11:03 a.m. I got the error message about microphone sharing and had the option to dismiss or reconnect. I hit dismiss multiple times and it kept the call connected. I got the error message a couple more times and hit dismiss and it kept the call connected. Eventually it became too distracting and I had to end my work conference call. At the same time as I got the error messages during the call, I ran a Republic Wireless diagnostic which I will send to you. Also you have my permission to pull whatever logs are needed on my phone. The call this morning that had the errors mentioned above was too a work conference line:■■■■■■■■■■■■■■■■and the call was made at 10:14 a.m.

1 Like

@southpaw @jben The other step I just took after having issues this morning is to deny microphone permissions to google messages and to turn off “chat features” in google messages. I doubt that will resolve anything, but that was the only app left with microphone permissions. Now it is only Republic app and the phone. Quick question: is it only the Moto G Power phones that are having this microphone sharing issue? Any reports of the same issue with other phones? I’m wondering if I need to replace my phone whether it would make sense to consider the Moto G power again or look at a different phone. Please let me know your thoughts. I like the Moto G Power in general, but if we can’t get to the bottom of this relatively quickly, I’d hate to get a new Moto G power and we have the same problem again…

Thanks for so much detail and effort on this @brandong.i1aaku! I’ve sent some instructions about the device logs to simplify getting those to the server.

Yes. At this time the G Power is the only this phone experiencing this issue, and only on a handful of those phones that have been activated on our service.

@southpaw This morning at 10:28 a.m. I placed a call into a work conference line:■■■■■■■■■■■■■■■■ At approximately 11:26 or 11:27 a.m. it handed over to cellular. At time of handover my wifi showed full strength and cellular showed about half strength. When it handed to cellular the volume decreased a lot. At about 11:29 a.m. I got the error message about microphone sharing and had the option to dismiss or reconnect the call. I hit dismiss and it kept the call connected. I ran the diagnostic through Republic app right away during the call and will email it to you. Also, I am going to send the logs to you the other way as well.

1 Like

it has happened once when I was not on Wi-Fi, and I do not have the CQATest app with permissions anymore, and the problem persists.

Hello, we have also just purchased a Moto G Power from Motorola, installed a new Republic sim card and have been dealing with this problem for the last 5 days. We have tried all of the recommendations so far on this thread post without success. Please let me know if a solution to this has been found.

Hi @sinkrote,

This topic will certainly be updated when a solution is found.

Would you mind disabling the Duo app and then let us know if the microphone-sharing message continues to interrupt your normal calls?

(Edited to add: Never mind the request to disable Duo. Another member who has been experiencing the issue has confirmed the issue persists with Duo disabled.)

Hi southpaw
I thought I would jump in here an let you Know that I have a moto g power that i got through google fi. It is the wifes an we have not had a problem at all about the microphone sharing.
we used it today on duo call with no tble at all… an every thing else is operating very good . No Trouble at all.

I also have not experienced this issue. For the record, I am on WiFi exclusively at home.

@southpaw Yes we did try the Duo disable and confirmed that this did not solve the problem. Please let me know if there are any other tests to try.

Are you keeping the phone in airplane mode with WiFi enabled?

Message an
Expert customer