Moto G will not stay connected to the internet


#1

Info

Phone Brand: Motorola
Phone Model: Moto G
Phone Generation: 1st Gen
Plan: Unlimited
Plan Option: WiFi and Cell Talk and Text

##Issue Description

For the last two days, my phone will not stay connected to the internet for more than a few seconds. It finds our internet, but usually won’t even connect to it. Every few times that I click on it, it will say it’s connected for a few seconds, but by the time I go to do anything it has lost the connection.


#2

Hi I suggest checking the wifi settings to maximize the wifi. Try the suggestions in this document and if your not satisfied with the wifi issue come back & let us know in this same thread.
[Maximizing your WiFi - getting the best from your Router/network]

~ ~~ßocephous™


#3

I would try forgetting the network and re-adding it.


#4

Hi @lynetteh.tke5et

In addition, it never hurts to reboot (power off/on) your router as well.


#5

Thank you for the suggestions. I’ve definitely restarted the phone and router multiple times and forgotten and re-added the network multiple times. I should’ve mentioned that.


#6

Whenever I see sudden changes in a phone’s behavior, I look for a misbehaving app.

Try putting the phone in safe mode to see if you have an app issue.

You might also try clearing the cache and turning off Bluetooth if you have Bluetooth turned on.


#7

Thank you for linking this resource. It doesn’t seem like it should be an issue with my router or internet as nothing has changed there. It is the same internet and phone I’ve been using for 2 years and the router is still working fine for all other devices on the network. I was trying to look at at least the first 5 things on that list anyway though…

First, do a controlled Power Cycle of your network … Power Cycle - fixes many problems (from the Checklist)
This is considered a ‘Best Practice’ and something that many of us do periodically.
I have no idea what this means or how to do it.

Ensure your Republic Wireless and Republic Telephony Apps are at the latest level Check or Update App directly from your phone3
My phone was telling me to install the latest app. But I didn’t get a chance to install it before I started having internet issues. The notification is still there, but I can’t download it without internet.

Test your Network …Using the above figures as a guideline you can run a test from your PC (with Java … which no longer works on Chrome. FireFox is ok), links and instructions in the INTERNET section of the Checklist to see where you stand
I don’t know what this means either. But I’m using my wireless internet with my computer right now to send this message so it seems that the network is fine.

Check your phones settings (1.0 &2.0 only) to ensure they are set to the ‘mandatory’ in the Router section of the Checklist - Phone Info
I can’t find this setting.

Check your Channel to see if you’re on a good channel for the router, nearby neighbors can be on the same or overlapping channel and cause interference.
I have no idea how to do this.


#8

Thank you for the suggestions. Shutting off Bluetooth fixes the internet connectivity issue. I can literally turn the internet on and off by turning Bluetooth on and off. So I was now able to install the update to the Republic app.

But this is still frustrating as I use Bluetooth pretty much all the time with my phone connected to Bluetooth speakers. How can I fix this problem?


#9

It is usually not bluetooth itself…but one of your apps that uses bluetooth. I had this issue with my Dunkin Donuts app for several months…until they finally updated the app. Take a look at this document to help identify which app is causing this issue for you


#10

Thank you, everyone!

Okay. So I tried restarting my phone in safe mode and it was doing the same thing. Then, it occurred to me that even though I was able to turn Bluetooth on (shutting off the internet), my phone was not connecting to my speakers. I looked closer at that and it was giving me an error message I’ve seen before. So I restarted the Bluetooth on my speakers and that fixed the issue there.

And then somehow it was all working at the same time even when I went back to normal mode.

I’m not sure what started this whole problem in the first place, but it seems to be working now. Thank you.


#11

It sounds like something with the bluetooth connection to your speakers was likely keeping the BT radio in your phone on and repeatedly trying to reconnect to the speakers, causing interference with wifi. Once your corrected the issue with the speakers, the phone was able to connect normally, not causing the BT radio to run overtime, messing up wifi.


#12

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.