Moto G1: can receive texts just fine, but texts always fail to send

Hi,
Starting a few days ago my Moto G (1st gen) can’t send SMS texts, but it receives fine. If I add an emoji, I can send too (I was told that this means MMS works). I am using the original “Messaging” app.
One of my google searches led me to an article that says that in 90% of the cases this is caused by a SMSC incorrectly set.


Unfortunately, I cannot use the author’s instructions to try to check for and fix that because the * # * #4636# * # * (no spaces) code doesn’t display anything** on my phone (RW’s Moto G1).
Before trying a factory reset (that the author says that might not solve the problem), which implies the pain of reinstalling the few apps I have, and updating everything up to the Android 5.1 Lollipop, I wonder how to check for that SMSC on my phone.
Thank you

Republic is, well, different and articles like that rarely apply at Republic.

The first thing to try is to dial *#*#8647#*#* from the dialer. It should quickly clear off the screen. When it does, wait 30 seconds and then restart the phone. Any change after that?

1 Like

Hi @mihais - we switched from the original messaging app on the G1 to Google Messages. Google Messages was much more stable for us. FWIW…

Thank you for your reply. I installed the “Messages” too. And behaves exactly same way.

Thank you for your reply. I went through that reset. I have an open ticket. But nothing worked so far. I am between a factory reset option, with all the time / pain involved, and using an emoji in every message I send, to use MMS instead of SMS.

When I try and fail to send, “My call and message history” (on RW website) shows Unavailable.

This seems to point to a kind of error like the one that article addresses: an incorrect setting of the SMS center number.

I already went through all these steps, with no result (including “safe mode”).
I have a second identical RW phone that works.

How to Refresh the Republic Wireless Activation

Network Settings Reset

How to Clear the Android System Cache on 1.0 and 2.0 Phones

How to Clear Messaging Data on 1.0 & 2.0 Motorola Phones

Update the Republic Wireless Application

Problems Sending and Receiving Texts on 1.0 and 2.0 Phones.

Not Receiving All Text Messages on 1.0/2.0 Phones,

Are you using the messaging app with the green icon (:messaging:) but any chance? If so, that app has been discontinued for quite a while and you’ll want to download Google Messages (:messages:) to use instead.

Thanks for your reply. I tried both (green and blue), and they behave the same way.
I can’t send text, and my attempt is logged on the RW site as “Unavailable”, but I can send text plus emoji, and my message goes through (which I was told that means that MMS works).

This bug happened in the last 10 days. I haven’t used the SMS in this period, and I had some regular android updates, maybe one banking app too, and I installed the Sam’s club app, which I already removed, with no improvement. At this moment I can’t say what event caused the bug.
The Unavailable message points to RW receiving my attempt to send an SMS, but finds something unavailable. I wonder what?

If you open the Republic App on the device, does it open normally? Is there any difference if the phone is on wifi versus not?

The RW app looks normally. There is the same behavior on wifi and cellular,

Ok, so the next thing I would try is clearing the data on the messaging app. You’ll get a scary warning about everything being lost, but nothing will actually be deleted. Give that a shot and see what happens.

I tried again: no result. I did it several times over the last couple of days.

Thank you for spending time to help me.

Do you know why I can’t use * # * #4636# * # * (no spaces) as is recommend for Android phones? Is it because of the changes that RW used to do in older days? Is there another way to access the same information? I would really like to check if the SMSC (Short Message Service (SMS) Center) is set correctly.

The last post on the page from the following link mentions SMSC too

https://www.howardforums.com/showthread.php/1863913-H2O-No-Texts-or-MMS!-Help-Please/page2

The proper SMSC (Message Center number) for H2O (RW)is:
+13123149 870 (without the space, but if I type it this forum blacks it up when I type the 8)
■■■■■■■■■■■■

I’m not sure what the relevance of an H20 setting is, but there is no manual setting for these types of things with Republic. You could try to uninstall updates to the Republic App and then restart the phone and then reinstall them which will force all settings to be reset.

Have you tried booting up in Safe Mode? just on the oft chance that one of you apps is contributing to your problem?
I would try that, if no joy … the next thing is a Factory Reset

Thank you for your suggestion. Is there a document that describes how to do it?

There is: How to Reinstall Updates for the Republic Wireless Application – Republic Help

Thank you for your reply. I tried the safe mode with no change in behavior.

I’m trying to avoid a factory reset, as that would involve re-loading apps and re-customizing. I’m pondering learning to live with emoticons in every message I send, especially as I am a light user both of the phone and of the messenger.

Who knows? It might go away with a future update. :slightly_smiling_face: (practicing emoticons …)

Thank you! I’ll look into it :slightly_smiling_face: (practicing …)

Should I do the same with Republic Telephony?

Message an
Expert customer