Moto G3 on Republic 2.0 no longer receiving cell calls - what have I missed?


#1

Hi, Republic experts and ambassadors. I’ve been having a problem with my Moto G3, and I’m hoping there is something you might know or remember that might help me out. Within the last couple months, incoming cellular calls have stopped working, although sometimes they would work if I made an outgoing cellular call first. The cellular signal at my home is pretty much full strength, with LTE, as the coverage map shows that it should be. When I make a call, the connection seems clear and stable. WiFi calls in both directions continue to work, no problem. So here’s what I tried:

  • Cleared caches (apps in Settings, system in Recovery mode)
  • Updated PRL, reset cellular credentials (via phone keypad), updated Profile
  • Reset VOIP credentials (via phone keypad)
  • Booted phone in Safe mode
  • Removed several applications (to ensure RAM usage was completely “normal”)
  • Uninstalled and reinstalled updates to Republic and Repub Telephony apps
  • Going in and out of Airplane mode, or booting in Airplane mode
    None of this made any difference, so then I decided to go for a Factory Reset (from the Settings menu). After the reset, all I did was let the phone activate, log in with my Google account, and install the latest updates for the Republic apps. No other apps have been installed.

But…I still had the same problem, so I contacted Republic Help. After answering several questions (yes, the volume is up, no, I don’t have all my contacts set to go directly to voicemail), the only thing else they’ve had me try is removing the SIM card (but the phone can only make emergency calls without it). I put the SIM card back in, no change. They asked for specific locations where I was having the problem, so I gave them a few. Last night I got a chance to try it about 40 miles away from home, still the same problem.

I subsequently tried another Factory Reset, this time from the Recovery Mode menu. No change.

When I power on the phone, incoming cell calls go directly to voicemail. The only thing that changes that is sometimes if I make an outgoing cell call first, I can then receive incoming cell calls. Other times the caller will hear a few rings before it goes to voicemail, but there is no indication of an incoming call, or one being missed. I do get a voicemail notification. Texting works fine. And as I mentioned, WiFi calling in both directions works fine.

So, I basically have a phone as close to Factory Reset state as possible, and I can’t receive incoming cellular calls on it. Can anyone think of anything else that I could/should try? I’ve run out of ideas.

By the way, my Help ticket number is 1-2-3-6-2-4-7, and (probably because it’s the weekend), I have not heard anything back from the Republic team since early yesterday, when they had me remove/reinstall the SIM card.


#2

Can you turn bluetooth on use bluetooth & turn it off manually without the bluetooth resetting to off position on it’s own?


#3

Yes, I believe so. I just paired a set of headphones with it, was able to play some audio, and then manually turned Bluetooth off. There was no unexpected behavior. The phone always connects to my car via Bluetooth and works as expected, other than not answering calls.


#4

That’s all I got! My question would lead to 1 more test to confirm a dead radio antenna in the phone. Hardware defect.
That isn’t a issue so I am all out besides rebooting the phone when doing clearing processes but the factory reboots knocked that out of the park.


#5

Yeah, what makes it interesting is that I can get it to work sometimes after I call out, which leads me to suspect some internal initialization setting that isn’t right (and isn’t getting set/reset properly) when the phone activates. It could also be something to do with the local network (or a combination of the two), but that gets a lot harder to diagnose, especially on my end. Thanks.


#6

Hi @flarewatcher,

You’ve done some excellent troubleshooting on your own. I’ve checked in on your ticket and made sure they are aware that you are still awaiting a response. Please let me know if you don’t receive a response overnight tonight.


#7

Thanks, southpaw. I just remember there was a lot of “community knowledge” around these types of issues back in the 2.0 days, so I thought I’d see if there was something obvious that I missed. Hopefully we can get it figured out.


#8

WiFi and Bluetooth are on the same IC (Integrated Circuits). The cellular IC’s are separate. it is possible the cell chip is malfunctioning.


#9

Just to close this out this thread, with Help Desk guidance I’ve tried an even “deeper” reset, and still no luck, so we’ve come to the conclusion that there must be some kind of internal failure/hardware problem. Looks like it’s time for a new phone. :slightly_frowning_face:


#10

If your phone shows a good LTE signal you may want to request Support send you a new SIM card to try prior to writing off your phone.


#11

The SIM card does seem to work, since I can access data (I did make sure that data still works), plus I didn’t think that the SIM was involved in cellular calling on CDMA phones. I do realize that the RW app uses some data in the background to “optimize” calling, although I believe it is not strictly required. During the debug process, I did remove and reinstall the SIM card. I also tried turning data off (all data, via system Settings), and there was no difference in behavior. But I can ask, and see if they think it’s worth a shot. Thanks.


#12

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.