Moto g4 play Touch screen not working


#1

Today my touch screen on the moto g4 play does not respond to touch.powering it down I had to remove battery . After restart it worked for a few minutes only to freeze up again not responding to touch. I use the pattern to unlock screen but this never appears on the home screen. Everything appears on home screen showing its locked but I have no way to unlock due to completely unresponsive to touch. I plugged my phone into my PC , but it can’t be detected until I unlock . Can anyone help me with this ? Phone is in great condition and these problems with the screen started showing up after updates…


#2

Hi @laurab.yspgid,

Have you tried clearing the system cache?


#3

I had to do a complete factory reset. I was pretty sure it was a software issue due to my phone having no damage and the touchscreen would work intermittently for short duration’s.
On another note I’ve been with republic for 4 years and was very pleased with how they continually worked and gave me better cell signal with each passing year. In fact prior to the updates from android and republic the cell signal went from OK to excellent , unfortunately after the updates the cell signal is now back to what it had been 4 years ago. I now frequently experience dropped calls and red messages stating no service , maps constantly looses GSM and its really frustrating. Did anything change with cell towers?


#4

Hi @laurab.yspgid,

Republic Wireless doesn’t own cell towers. We partner with two of the nation’s largest carriers and your cellular service is provided by one of those.

Since you’re discussion the coverage question in another Community topic, and the touch screen issue was resolved with a factory reset, I’m going to close this topic. We can focus the conversation about the coverage issue in your other topic, here:


#5