Moto G5 Plus, calls only work on WiFi

#1

About one month ago I went from a Moto G (1st generation) to Moto G5 Plus with absolutely no problems. On Wednesday night, my husband received his new Moto G5 Plus and we’ve had a horrible time migrating over. We had to request the new phone activation twice (we waited three hours before realizing it wasn’t going through) and then, after it appeared everything was up and running, we began receiving a message from his new phone that his account could not be validated. After doing some reading, we found that we simply needed to unistall the Republic Wireless updates and then reinstall them … it worked. UNTIL the next morning (yesterday), when he began receiving the same message again; so, we repeated the “fix” and it appeared to work … until now. He can’t receive or send calls when he isn’t connected to WiFi. I should note that he can text without a problem. We’re getting pretty fed up with the whole situation …

#3

Hi @aaronl.c2nvmx,

Your issue sounds more complex than our Community can fix. Please open a support ticket at http://republicwi.re/myaccountsupport so our technicians can help.

2 Likes
#4

Hi @aaronl.c2nvmx

Sorry to hear you are having issues on your second Moto G5 Plus. Have you tried simply restarting the device?, (often an overlooked simple fix so just checking).

You should also review the troubleshooting section of Make and Receive a Phone Call – Republic Help document.

You may need to raise a Support Ticket or initiate a Live Chat if the above suggestions fail to resolve the issue you are experiencing.

Please keep the community updated on this issue and we will try to assist you in getting the phone working properly.

1 Like
#5

Yes, we do restart it after the new installs - thank you :slight_smile:
This is quite frustrating …

#6

I just wanted to provided an update. I received a fix from RW and it seems to have cleared up the problem. Below is the response:

**We understand that your new G5+ isn’t working for cellular calls. This issue has continued, even after reinstalling the Republic Wireless app. I’d be happy to assist with getting this issue resolved, which I’m confident we can get done with just a few steps on the phone. **
You mentioned the error you hear is “Your account cannot be validated.” This is usually resolved by following the steps below to reset your phone’s cellular settings:
First, please make sure the phone is connected to WiFi.
From the ‘Phone’ app, open the dialer, dial ## 72786 ##.
Select ‘OK’ on the Reset menu that pops up (No personal data will be lost).
Once the phone has rebooted, please ensure you’re still connected to WiFi and go to:

  • Settings > More…> Cellular networks > Carrier Settings > Select Update Device Config.
    You should then reboot the phone and try calling out on the cellular network, perhaps by turning off WiFi to test.
1 Like
closed #7

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Message an
Expert customer