Moto G5 Plus dropping wifi

wifi

#1

I switched from my 1st gen Moto X to a Moto G5 Plus in November or December, forcing me to move to the new My Choice plans. I have 1 GB of data, because I only ever used up to 0.5 GB before.

How I use my phone hasn’t changed significantly, but the new phone is using nearly double the data. I finally noticed what I think is the culprit, it is dropping the WiFi connection. I can’t tell if it’s random or after a certain period of not using it. It’s doing this everywhere: stores, work, and even when at home where there are only three devices on my WiFi.

So if I’m at home or work I can put my phone on airplane mode with WiFi on to avoid using the cellular network, but it still drops the connection sometimes and then it just doesn’t get anything. Since I’m turning off the cell network to do this, I don’t have a backup network so I really don’t get anything, not even texts or calls, when the WiFi drops. I’d rather that the system works how it is supposed to work and I don’t have to micromanage to avoid being on the cell network while at home or work.

I know that most computers have a setting where you can prevent the wireless card from going to sleep, is there something like this that I’m missing in my configuration of the G5 Plus?

Thanks,
Jon


#2

My G5 Plus is rock solid on WiFi.

There is a setting “keep WiFi on during sleep” - set that to “always”


#3

The are a couple of problems that could cause WiFi to drop and use Cell data when a ‘good’ WiFi is available

  • If an Android device is left idle for a period of > 1 hour, network connectivity is dropped (part of Doze) … this is normally at home/work and can be overcome (in most cases) by turning on the display. Many have implemented a ‘fix’ that @billg documents in Are your calls going to voicemail when your phone is sleeping?
    • I have found that turning on the display for 1 sec, every 55 min keeps my Moto X Pure alive and connected
  • Android allows ‘Developer options’ and one of these is ‘Aggressive Wi-Fi to Cellular handover’
    • It appears that this function does what it says, so should be avoided unless that is your intent
  • I do not have a Moto G5, but am not aware of any Android settings that could affect your WiFi across multiple environments

#4

Thanks, I moved my battery optimization setting to hopefully prevent the RW app from going to sleep. (That was the final solution for @billg.) Maybe I should try the app though. I double checked and I didn’t have aggressive handover turned on.

@ceedee I checked and I had already enabled the setting to keep wifi on during sleep.

The odd thing to me is that this isn’t just happening when the phone is untouched. I can pick up my phone at home and start using it and then realize a few minutes later that it is still on the cell network. I would expect it to connect to WiFi within at least a minute of me picking it up and starting use, even if it turned it off because I wasn’t using it for an hour.


#5

I am having the same problem on a moto x pure edition that I just upgraded to from a 1st generation moto x that was working fine. No change in my router. Wifi set to “allways on”. If phone asleep for 1-2 hours, arc is open and on cellular. If I unlock the phone, it will got instantly to wifi with closed arc. However, the will come in on cellular. If I have the person call back immediately, it will come through on wifi.

Does Republic have a solution to this or is Macrodroid the only solution?


#6
  • I am not aware of any solution from RW, they have implemented Goggles latest Firebase Cloud Messaging (FCM) as part of the WiFi call set up, but from all reports I see (both here and across other phones/carriers & Google forums) it appears that there are still timing conditions that can prevent incoming WiFi calls. Republics normal error recovery when you are 'not found on WiFi’is to route call via cell, and then if your WiFi is ‘ok’ and you have ‘Handover to WiFi when appropriate’ check in the RW App Advanced settings you will see the call auto transition to WiFi after 45sec

When do we get new phones?
#7

Do any of the “keep wifi on” apps in google play work or have you tried
them:

Wifi no doze, best wifi keeper, keep wifi on, keep wifi alive, keep wifi,
etc

Thanks,
Parag


#8

I have tried most apps I can find with no success and read many of the discussion/tickets in the Android bug tracker and there does not seem to be a single cure all


#9

Well, I’m still having wifi issues, but whatever, I’m kind of giving up. I have even had to reboot the phone a couple times to get it to use a wif network. It just won’t even log in, even when I manually go in and tell it to use a particular wifi network. This has happened at work, and then the other night at a friends house, both places where it has connected without issue before. I don’t know if this is happening with my wife’s phone, as she likely just wouldn’t notice.
I may just go back to a no data plan, as I think that will annoy me less than wifi not taking over when it should.


#10

Same problem here. Went from a Moto X 2nd gen to a Moto G5 Plus. The wifi seems to be terrible with certain access points. The wifi frequently drops while I’m using the phone. Or, sometimes the wireless performance will be unusable (I’ve run speed tests that come back at .02 Mbps). Meanwhile, a laptop and my old phone work just fine from the same exact spot connected to the same wireless access point. According to the access point, the signal strength is nearly identical between all 3 devices. My Moto G5 Plus indicates it’s connected at 72 Mbps, yet it gets less than dial-up speeds at times. If I move across the building and connect to a different access point (an old 802.11g one), it works fine.


#11

As the Moto G5+ and the majority of the new phones support 802.11ac with the newer chipset there is a possibility that there is an ‘older device’ on the AP that is causing a problem?

  • Any chance that you can turn off all devices on the particular ‘bad AP’ and retry?

#12

That’s a good suggestion and I had a similar thought as well. Unfortunately, the problem is in my office at work, so I can’t do that. However, I do use the same access point at home (Cisco 1141 802.11n AP) and I haven’t noticed similar issues (I’ll need to keep a closer eye on it to confirm that). If that is the case, that would further leading me to believe it might have something to do with other devices on the network. Next time it’s experiencing issues, I’ll look more at the other clients connected to it. Maybe see if there’s an old 802.11g device or something connected to it.


#13

same exact thing for me with my moto g5 Plus


#14

Exact thing … ?? more info please

  • What Router/Access point have you seen the failure on?
  • If it connects, what speed does it show connected at and 2.4 or 5 GHz In Setting /Wi-Fi , the info on the Router/AP you have authenticated to
  • have you tried McD or Starbucks WiFi
  • Describe your failure as completely as you can.

#15

wifi drops in an out. Have no idea why. Works fine on some access points but in my rental it does not hold access on a wireless access point that has both 2.4 and 5 GHz networks. I don’t have access to the wireless access point so I’m not able to do anything to it. However, my desktop (iMac) stays connected rock solid - no problem. It’s just the Moto G5+ phone that goes in and out, and I always have my friends test with their phones when they’re visiting - iphones & droids, no other devices are having the issue.


#17

This is a HUGE issue with the Moto G5 Plus phone. 100s of users are having WiFi problems with their moto g5 plus phones, and it is a software issue on the manufacturer’s part, and they are unwilling to fix it even after a year, or they just haven’t figured it out yet as seen here on this forum which has 55 pages of people posting about the same issue: https://forums.lenovo.com/t5/Moto-G5-Moto-G5-Plus/Moto-G5-Plus-wifi-problem/td-p/3618235/page/55


Notable Newbies: Welcome!
#18

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.