Moto G5 Plus (G4, G4 Play) not connecting to Cell Service

moto
clearchoice_plan

#1

Phone: Moto G5 Plus
Plan: Clear Choice
Plan Option: Talk & Text, with Cell Data.

My newly activated Moto G5 Plus is not connecting to cell service even though I have coverage in the area. I cannont send or receive text messages through cell service either. Has anyone found a solution to this issue? I have done all of the restarting, uninstalling/reinstalling the RW App, and even resetting my network coverage. I have submitted a help ticket. RW responded once and then stopped replying.


New Moto G4 Play No Cellular Data
Can I use my old RW sim card?
Ordering a SIM card
#2

When was your last contact with support? Can you please post your ticket number?


#3

I’m having the exact same issue with my new G5 plus as well. My ticket number is # 1 1 5 2 0 1 6

I last heard from support this morning.

Seems like a similar issue to the other thread on here. I have a ! next to my cell service on my phone and can’t send texts or make calls when I’m not on wifi. SIM card issue?


#4

Hi @emilyf,

I want to make sure your ticket is in the right queue.

Could you please tell me whether you are able to make calls on cell? And if you don’t mind, can you tell me whether you are currently located in the city we have on file for you, or if not, what city you’re currently in?


#5

My wife and I both got new phones (G5 plus) and are having the exact same issues. When I’m out of wifi range, or I turn off wifi, I see the little exclamation point next to the cell signal symbol and I’m unable to send or receive texts. My previous republic phones (both Moto G 1) worked perfectly with no signal issues. My phone says it is connected to a cell network, but then I get an error about messages not sending.

Ticket number 1 1 5 1 8 8 2

Heard from support about an hour ago to try out reseating the sim card and some more checks on settings.


#6

Hi @joshuah.naxaku,

Are you able to make and receive calls when on cell? Could you also tell me your location?


#7

Thanks @southpaw

I am not able to make calls. It just says dialing and hangs (no ringing and not call timer started). I’m in Rochester, NY.


#8

Thank you @joshuah.naxaku,

I’ve noted those additional details in your ticket and have made sure the ticket is in the right queue. Our technicians will keep researchng the issue for you.


#9

What SIM card did you use? The new one that came with the phone, if bought from republic? Did you buy a SIM or did you swap one from an older republic phone?


#10

I used the SIM card that came with the phone, bought from Republic.


#11

I am currently in the city that is on file. I cannot make calls over cell either


#12

I used the new one that came with the new phone from RW


#13

Thank you very much for the additional information! I’ll make sure your ticket includes these details and is in the right queue.


#14

The last contact on my ticket was yesterday
My ticket number is # 1 1 5 1 5 1 9


#15

Looks like @southpaw has already located your ticket… you are in good hands! I hope your issue gets resolved soon… I just activated a G5+ yesterday, looks like a nice phone!


#16

I also have just bought a moto G5 Plus I’m having the same issues someone emailed me earlier today wanted to screenshot of my sim information and phone info and I have yet to hear back…ticket #1 1 5 2 3 3 1


#17

I am having the exact same issues. Moto G5 plus having no cell service at all. Help ticket contacted me once. I followed procedure and they asked for a screen shot of WhatsInSIM app data. I haven’t heard back. That was this morning, so not too long.

Pretty frustrating that my old phone is better than my new one.

Ticket #1 1 5 2 3 7 9


#18

I have the same issue with my new MotoG5plus. I just opened a ticket.


#19

@jeremye.ce9egc and @travisc.nrpols,

Thank you for joining this thread. We are investigating all these tickets I will make sure you are included with updates. I have to do some research on each ticket, because sometimes when people say, “I have the exact same issue” there are some subtle differences that make it a whole different issue, and we don’t want to waste time treating the wrong issue, for anyone.


#20

Cellular icon has “!” when not connected to wifi. My other RW 3.0 phones work completely, including another one I just upgrade from 2.0 to 3.0 plan.
RW app and email from them shows successful activation and the app and online shows 1 GB cellular data plan/available, but shows no usage of cellular data.
I upgrade a Moto X 2.0 plan phone to Moto G4 RW 3.0 plan phone.
RW had me try * # * # 8647 # * # *, then Network Settings Reset, same problem. I then tried factory reset, put the Moto X 2.0 plan phone back on as a test and it still works, I put Moto G4 back on and same problem, I’ve rebooted, confirmed cellular data and roaming are on, LTE, and so on. Still a ! at cellular icon. I tried using 3G and 2G as test, and 3G worked briefly then started showing !

I compared Moto G4 to Moto X pure and I did notice Moto X pure had a RW VPN entry but Moto G4 does not. I don’t know if this is indication of problem.
Any ideas appreciated, I’ve tried and re-tried everything I can think of or find, and RW hasn’t responded since they 2nd thing they recommened, Network setting reset, didn’t work.