Moto G5 Plus-iPhone's not receiving texts

What phone do you have? Moto G 5 plus

What plan are you on? 3.0

Does your plan include data, or just talk & text?
Talk and text


Issue Description

Tried everything but cannot text to iPhones

Hi @carolinem!

What texting app are you using?

mb2x

If u are referring to a person using an iPhone that is using iMessage, this is because iMessage is not a normal SMS/MMS texting app or service. It is exclusive to iOS and is not compatible with Android users. (same thing with FaceTime)

If you are sending a normal text (SMS) the iPhone user should receive it as a normal text via its built in Messages app.

Normal text…just started tonight

The default that comes with phone… problem just started this evening after texting to iPhones for months

Did the messages actually send (it should say the time/date under the message)?

It says they are sent… no iPhones are receiving my texts… I was texting iPhones then I went off WiFi and soon as I connected iPhones stopped receiving… I only texted no iPhones while not on wifi

Have you tried to text non-iPhones off WiFi? I would say you may want to reboot your phone and see if that fixes it (for starters).

Tried all the fixes in the help document which included restarting the phone after each thing. Texted to iPhone off WiFi this afternoon.

Ok. What happens if you text an Android phone without WiFi? Do they recieve it? Also, do you know if you have a GSM or CDMA phone?

No texting issues to Android… not sure it’s just a Moto g 5 plus from Republic…started a couple hours ago… tried clearing cache, etc

Did it start at around 6:29 PM CST?

My phone (S8) will receive calls + texts, but I cannot send text messages. I’ve tried using Everywhere as well as Textra, neither work. Texting a Pixel 2 however, and not an iphone.

Hmm… what happens if you download and install the Republic Anywhere app and set it to send text messages. See if they recieve it without WiFi.

7:20 EST it started

What happens when you try to send the messages?

‘Successfully’ sends as reported by the application (Textra, Android Messages, Republic Everywhere) but the receiver never gets it

So, almost the same time then

Is this under WiFi, cell, or both?

It says it sent but it is not received by the iPhone

Both, disabled WiFi in an attempt to send a message and had the same result.

Message an
Expert customer