Moto G5 Plus not ringing on incoming calls - However Extend Home phone is ringing

What phone do you have?

Moto G5 Plus

What plan are you on?

My Choice - It just renewed on 5/19/21

Does your plan include data, or just talk & text?
1 GB data


Issue Description

I have just noticed the past week that I am not receiving incoming calls on my cell phone. It is obvious because I have the Extend Home ip phone and that always rings. When I dial ##72786## it disappears but else nothing happens. I restarted my phone and tried it again to no avail. Trying to avoid a factory reset.

Try refreshing the Republic Wireless activation:

2 Likes

Thanks, that did the trick.

2 Likes

My phone quit ringing again. Refreshing the Republic Wireless Activation is not working now. I have done it 3 times and it will not ring. I can call out fine.

When you say it quit ringing, what exactly does that mean?
If you place a test call and the Extend Home is ringing, does the cell phone’s screen light up with an incoming call screen?
Do you see a “missed call” notification on the cell phone after the Extend Home’s ringing stops?
Or is the phone completely unaware of the incoming call?

What does “is not working” look like? Does this mean that when you follow the steps to Refresh the Activation nothing apparent happens on the phone’s dialer, or does it mean that you complete the steps on WiFi and reboot the phone, but the phone still fails to ring?

The cell phone doesn’t realize there has been a call. No missed call notification. Completely unaware.

I completed the activation steps on Wifi and rebooted the phone.

Thanks @davidl.0hwgh1,

Do you have any call-blocking apps or the spam-blocking settings enabled in the Republic app?

Is your Do Not Disturb by any chance on, and set to “No visuals or sound from notifications”?

What is the cellular signal like at the location where this is happening? (Or, is it happening everywhere you go?)

Good job. I just checked the Republic Wireless App for Spam Call Blocking and numbers not saved in my phone were set to go straight to VM, however they weren’t doing that, but ringing on the Extend Home phone. Allowing calls from unsaved numbers has appeared to fix the issue.

This was a tricky one to diagnose. Conflated the issue my reactivating the phone and also saving a number to contacts without realizing that Spam blocking was the issue. When that number rang through I thought the reactivation was the fix. Not!

I hope that solves it for you with no more complications! :crossed_fingers:

:thinking: This is how it’s designed to work, because we don’t copy your phone’s contact list to our servers to determine whether or not to route calls to Extend Home. Spam settings that rely on what is saved to your phone, will not prevent calls from ringing Extend Home.

(We send calls from our servers to your phone AND to Extend home. You may be envisioning it as us sending calls to the phone and then from there to Extend Home, but it’s two separate branches.)

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer