Moto G5+ Will Not Block Calls That Are Not in Contacts

In settings.
I chose:

  1. Do Not Disturb Preferences
  2. Priority Only Allows
  3. Calls
  4. From contacts only

Fails! All calls still ring.

Thanks in advance!

Hi @garyb.tiqdmy,

Are you trying to block calls (as your subject line mentions) or prevent the ringtone from being heard?

Priority mode isn’t mean to block calls, only to silence the notification.

To block calls, take a look at this:

2 Likes

Southpaw,

I need to prevent the ringtone from being heard…minutes ago I found the “Priority Only” setting and it seems to be working!

Simply pulled the notification shade down from the top and pressed Do not Disturb!

THX!

1 Like

Now I understand! The settings you described in your first post define how you want “Do not disturb” to behave. But you still have to toggle it on or off in order for it to behave that way.

Glad you figured it out!!

1 Like

This app may help with the Do not Disturb settings.
Read this in tips & Tricks

Thanks for the help. Will try the app.

1 Like
Message an
Expert customer