Moto g5s+ on android 8.1.0 with cdma sim card doesn't use wifi to receive or make calls

What phone do you have?
Moto G5s plus

What plan are you on?
talk text and 1 G data

Does your plan include data, or just talk & text?
1 G data


Issue Description

Basically since I got my motoG5s+ with CDMA card, I’ve had problems using it on wifi. it came with a GSM card which worked great on my home wifi good as I have very little cell signal at home. however, that doesn’t work on cell in the rural areas of VA and ME that I frequent. So I got a CDMA card. It does fine with text, email, browsing, even streaming and it doesn’t receive calls or make calls over the wifi.
we have satellite internet. and it’s sufficient for streaming, skype, zoom, etc, most of the time. And worked with the GSM card.
I ran diagnostics and it says, in brief, Voip network performance is too uneven, too delayed, and too much data loss.
I’m perplexed as to how I can stream and yet not make calls.
Is there anything I can do?

It really shouldn’t matter which card you have in the phone. Consumer satellite internet is just not recommended for voice calls. If you have a cellular signal at home, calls should complete satisfactorily over cellular.

1 Like

Thanks. That’s the issue…I have lousy cell signal at home. My previous Moto G4 used wifi for calls with ease in the same home with the same wifi and this one doesn’t??? so not ok.
Very much a first world problem…and I am trying to run a business. stinks to have to run to the part of the house that may have sufficient cell every time I have to make a call or the phone rings.

My guess would be that the GSM card has a more usable cellular signal in your home. So while you thought the calls you placed/received occurred over Wi-Fi, they may have switched over to cellular, or used the cellular data channel.

1 Like

Hi @auroraw.i70oiu - I suspect that @cbwahlstrom is correct about the underlying issue. Have you tried turning on airplane mode then enabling WiFi and them making some test calls and texts? This might give you a better idea how RW operation is over your WiFi. Here’s a How to for How to Test Calls or Texts on a WiFi Network – Republic Help

This might at least help confirm it’s a Satellite WiFi issue.

1 Like

Which Satellite provider are you using? I’ve seen some limited success with viaSat but not HughesNet or legacy Dishnet Satellite services. Even the HughesNet Gen5 system, which claims VoIP support, doesn’t seem to work.

We’re on viasat.

Aurora Walks Gently

I would try the trick of putting the phone in airplane mode and then manually re-
enabling wifi. When you do that, will the phone make/receive calls over the wifi?

It works fine if I put it in airplane mode. I thought republic was supposed to use wifi when available? I’ll just have to muck with it.
Thanks. Aurora

Aurora Walks Gently

I’m guessing, but in an educated way here… Republic’s system works to blend wifi and cellular. Satellite internet connections introduce delays into the wifi traffic due to the nature of the system (signal has to travel 23,000 miles each way to the satellite and even at the speed of light, that adds almost a half second of delay on a round trip which is an eternity for real-time conversation. Republic’s system is constantly monitoring the wifi quality and detects this delay (and worse, any variability in this delay (known as jitter)) and when it believes it is decreasing call quality, transitions your call to cellular. This could be as soon as during the dialing process.

When you disable cellular, the system has nothing to fail over to, so instead maintains the call over wifi for as long as possible as long as the call doesn’t actually drop.

Message an
Expert customer