Moto G6 Has Gremlins

What phone do you have?
Motorola G6

What plan are you on?
My Choice

Does your plan include data, or just talk & text?
Just Talk & text, but I occasionally add 1GB of data each month.


Issue Description

I purchased this phone in October 2018. Over the past several weeks I’ve downloaded a few 3rd party apps (Instagram, Garmin Connect, and Double-Twist). Not all at once, mind you, and each has worked fine. The phone was working fine prior to these additions and was working fine with each of these additions until just this last week. The first thing I noticed was the battery was draining more quickly and found that for some reason the Republic Anywhere app was using battery, but I don’t use the Anywhere app…I’ve never even set the account up, so I uninstalled the app to see if that would fix it. It’s better but still draining battery quicker than normal. Then I noticed the Instagram app wouldn’t play videos in my newsfeed or in stories and that problem wasn’t isolated to our WiFi…it does it on other WiFi and data too. I tried all of the troubleshooting tips for fixing that problem that I found online, but none of them worked. Today I noticed a new problem with the camera, when I take a picture it says it’s “processing” then the picture disappears and I can’t find it in any of the folders both internal and SD storage (I actually formatted the SD as internal storage), but if I take a picture in the message app to attach it to the message, it works fine, but it doesn’t save it in any of the folders…only in the message itself. And last but not least, the Gmail app won’t load attachments, and there’s are a few app updates (Facebook, Google Chrome, and Google) that refuse to download, while other updates have downloaded. I did go in and clear app cache and data on the Play Store app. These seem to be unrelated issues, but I’m hoping someone has some insight. I really don’t want to have to do a factory reset…I hate doing that.

Sorry that none of us has joined your ‘Gremlin’ hunt
As you state, the last thing you did was download a few 3rd party apps … lets try to peel back that onion a bit, as often a combination of apps can be the source of problems.
I would suggest the following (1 at a time until success)

  1. Clear Cache (both system and app)
  2. Boot up is Safe Mode
    • This will prevent all the 3rd party apps from loading
1 Like

Thank you, jben, for your reply! I have cleared cache on all apps, cleared Android cache, and rebooted in safe mode. The camera is still not saving pictures, and the updates on those 3 apps are still not downloading. I’m thinking I’m going to have to take the plunge and do a factory reset.

Hi @jenifern.rvjzir,

If you haven’t already done that factory reset, does the phone behave any better if you turn off Bluetooth?

1 Like

I typically leave Bluetooth turned off unless I’m in my car and have it paired with my stereo or if I need to sync my watch. I don’t use the paired phone notifications on my watch…so it’s turned off more than it’s on.

You formatted the SD card as internal storage… are all these apps that are misbehaving by any chance using that SD card?

You have several issues going on…but the one I can speak to is

On my X4, photos takes from the messages app…are saved in a separate folder called “Messages”… they do not appear in the chronological log of photos on first opening Photos app.
However, if you browse to Albums -> Photos on Device -> Messages then I do see my Messages photos over there. I don’t have this folder synced with Google…so they just remain on the phone and will not be backed up to Google.

Thank you for your response! I do have my messages folder synced with Google Photos, but they’re not even being saved to that file.

Yes, I have moved all possible data to the SD storage, so these apps are most likely using this SD card.

Is it possible that having formatted as internal storage has caused the issues, or has the SD card possibly gone bad? When I decided to format as internal, I figured since I was only planning on using the SD card for this device, I didn’t want is as external.

I don’t think formatting it as internal storage has caused the issue, but the possibility that the SD card is corrupted is would by my top suspect at this point, if it were my phone.

I was kind of leaving it here in the hopes someone smarter than I would chime in on possible solutions.

Haha! Thank you! I will also leave it here to see if anyone else agrees with you or has even more insight. That is a good thought! I hadn’t thought about the SD card being corrupt. I did wonder if some type of virus would cause these issues.

Just an update for anyone following this thread… I ejected the SD card and all of the issues were resolved (at least everything other than the battery drain issue. That will take a day or two to determine whether it’s resolved)…I plan to use the phone for a few days without an SD card to see if the issues reappear. If they don’t, then I will reinsert and reformat the same SD card to see if they return. If they do return, I’ll know it’s the SD card and I’ll get a new one. Thanks for the troubleshooting help!

5 Likes

Thanks, @jenifern.rvjzir, especially for taking the time to give us a follow-up. I had read that you’d have to factory reset the phone after having the S&D card formatted as internal memory, so I’m relieved that doesn’t seem to be the case.

Thank you, @southpaw! I’m relieved, too!! But I’m also prepared to factory reset if I need to… everything is backed up!

1 Like

Hi, “Wonder Woman!”

I haven’t seen/heard anything about Bluetooth in regard to issues like this. I apologize in advance for not taking the initiative to research this on my own, but do you have something easily accessible/handy for me and/or the OP to look at that touches on this?

My impulse would be to recommend uninstalling the most recently installed apps, not only to account for incompatibilities but also to free up internal storage – even if that would only be a short term fix, a few hi-res pictures or videos could easily [re-] create an internal storage choke point.

Also: Good onya to @jben for his suggestions here.

Please pardon my virtual limp in this “walk through.” I am trying to rehab myself here despite asking you for a shortcut fix based on your efforts and not doing the exercises i need to be doing.

Well, my gremlins were eradicated by ejecting the SD card that I had formatted as internal storage. It appears that the SD card had been corrupted. When I tried to reinstall the same SD card, I got an error message and it wouldn’t let me reinstall it. I purchased and installed a new SD card and it’s working great! So my deduction says it was a bad SD card.

4 Likes

Thank you for taking the time to provide what I consider to be helpful, and in my case, educational feedback on your troubleshooting results.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Message an
Expert customer